cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jianwei
New Member

Unable to save when granting Row Level Security

Hi 

 

Would like to know if any of you are experiencing issue saving when granting row level security?

I am able to add the user into the row but when I click save, it takes forever to save and an error message throws up

jianwei_0-1610961215296.png

 

Would need help to resolve this soon. 

 

Thanks

1 ACCEPTED SOLUTION

@jianwei You can switch that in workspace settings > Premium > Premium capacity.

012503.jpg

View solution in original post

8 REPLIES 8
Anonymous
Not applicable

I'm assuming this also affects adding internal users?  Several of us are experiencing the same issue when trying to add internal users.

negi007
Super User
Super User

@jianwei I hope your issue would been resovled by now as it was a technical glitch and Microsoft has already deployed a fix for it.

 

Power BI customers with premium capacities using Row Level Security may experience issues while adding external guest users (AAD B2B) to roles with the message, "The Role could not be updated. Please try again later". As a workaround, users can move their workspace to Shared, add the external guest user, then move it back to the capacity. Engineers have identified the issue and a fix is expected to be deployed by end-of-day 02/20/2021

 




Did I answer your question? Mark my post as a solution!
Appreciate your Kudos


Proud to be a Super User!

Follow me here


Hi negi007

 

I believe the issue is still there. I tried it awhile ago and the error message is still there. 

jianwei_0-1611558449974.png

 

v-jingzhang
Community Support
Community Support

Hi @jianwei 

 

There is an issue with premium capacities using Row Level Security. You may try the suggested workaround below. Support | Microsoft Power BI

012102.jpg

 

Regards,

Jing

Hi Jing

 

Thank you for the reply. 

 

Could you share how I can move the workspace to shared and then move it back to the original workspace?

 

Apologies if its a stupid question

 

Thanks

@jianwei You can switch that in workspace settings > Premium > Premium capacity.

012503.jpg

View solution in original post

Hi JingZhang 

 

Thank you for the work around! Have accepted it as a solution.

 

 

rahul_w
Frequent Visitor

Hi  @jianwei 

 

Are you using Power BI premium capacity workspace? If yes, then please check below support URL in the awareness section.

 

https://powerbi.microsoft.com/en-us/support/

 

This is a global issue and will get fixed on 19 Jan 2021. You can try the workaround suggested.

 

Thanks,
Rahul 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Kudoed Authors