cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
quinncallan Frequent Visitor
Frequent Visitor

Unable to properly export special characters to .csv

Hi Guys

 

When i export a report from Power BI to excel it does not correctly export the special characters, e.g. Životná is exported as Životná

 

I have a feeling it is something to do with exporting to .csv....is this the case? any work around?

 

Duane

3 REPLIES 3
morph268 Frequent Visitor
Frequent Visitor

Re: Unable to properly export special characters to .csv

This is because Excel by default open a CSV file as text file.

 

As a workaround, you can do the following:

1. Open Excel
2. Import the data using Data-->Import External Data --> Import Data
3. Select the file type of "csv" and browse to your file 
4. Change the Delimiter to comma
5. Select where to import to and Finish
6. You can go ahead and remove separator instruction.

 

https://help.tune.com/marketing-console/how-to-import-a-unicode-csv-to-excel/

 

 

 

Highlighted
morph268 Frequent Visitor
Frequent Visitor

Re: Unable to properly export special characters to .csv

and of course you can save-as XLSX after the import; so you don't have to keep repeating yourself

Grumelo Regular Visitor
Regular Visitor

Re: Unable to properly export special characters to .csv

 

Power BI desktop is generationg CSV using UTF-8 encoding with , as the separator and Excel is by default using ANSI encoding and the separator defined at Control Panel / Region and Language / Advance Settings / List separator (you may need to change it to , )

 

Using the Import Wizard of Excel let you choose the encoding (you have to select UTF-8 at nearly the end of the list) 

 

Problem with the Import Wizard is that Line Feed (cariage return) will screw your data.

The Wizard is not able to deal with them.