cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TMELN21
Frequent Visitor

Unable to connect to data source undefined

Hi, I am having issues refreshing my data on PBI online with the following message coming up when trying to refresh my dataset

 

"Unable to connect to data source undefined"  

 

  • Cluster URIWABI-NORTH-EUROPE-C-PRIMARY-redirect.analysis.windows.net
  • Activity ID7dcceefa-1cc9-4198-a09b-812ec3638f03
  • Request IDf9e63a38-af5a-df5f-28f4-2435d627c6a2
  • Time2022-01-19 13:56:09Z

 

I have tried various fixes such as privacy level settings, database name check, re-installing gateway, using only one data source.  Under settings>gateway>Data Source Settings I get the message that the connection is succesful but again when I go to refresh i get that same error "Unable to connect to data source undefined".  I have been trying for a number of days now and have totally hit a brick wall, any help would be greatly received.

 

5 REPLIES 5
Icey
Community Support
Community Support

Hi @TMELN21 & @J-MJE ,

 

Please give me some information to help research the issue:

 

1. What's the version of your Power BI Service and Gateway? Have you tried the latest version of gateway?

 

2. What's your data source and the privacy level? Are all data sources the same privacy level?

 

3. Is this issue with all reports' refreshes, or just this one? 

 

4. Is the workspace involved classic (v1) or new (v2)? Have you tried both v1 and v2?

 

5. What's the license mode of your workspace?

Icey_0-1642993870163.png

 

6. Have you tried to delete and re-add the data sources in gateway?

 

7. When did this issue appear? Did you make any changes before or after it occurred? 

 

 

Best Regards,

Icey

TMELN21
Frequent Visitor

Hi @Icey 

 

1. Current version of Gateway is 3000.110.5, Current version of PBI Desktop is 2.100.1401.0, Current version of PBI Service (not sure where to find this)

 

2. Data source is SQL and Privacy level of "Public", only have the one data source currently.

 

3. I have the same issue with another report

 

4. The workspace involved is V2, I havent used the V1

 

5. License mode for the workspace is Pro

 

6. Yes I have tried deleting and adding the data sources in the Gateway

 

7. Issue appeared December

 

Thanks for your help

 

TM

J-MJE
Frequent Visitor

Hello Icey,

 

I am not sure exactly what was changed or fixed, but later in the day everything began working again. I'm assuming it was probably something on my side somehow.

 

Thanks

Icey
Community Support
Community Support

Hi @J-MJE ,

 

Anyway, glad to hear the issue is gone.

 

@TMELN21 How about yours?

 

 

Best Regards,

Icey

J-MJE
Frequent Visitor

I'm experiencing the same error. I can also confirm that the gateway does not seem to be an issue, as all of my powerapps that are running on the same gateway are working fine.

Helpful resources

Announcements
Carousel_PBI_Wave1

2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.

Top Solution Authors
Top Kudoed Authors