cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dfordhiraj Frequent Visitor
Frequent Visitor

Unable to connect to Oracle 12c DB.

Hi - 

 

Trying to connect to Oracle Data base on prem. Installed the gateway and entered the database connection which went fine. Made sure the names are same. 

 

I am able to query and publish a simple extract to powerBI. But when trying to  open on the site. It errors with the below error. 

 

Couldn't load the model schema associated with this report. Make sure you have a connection to the server, and try again.
Please try again later or contact support. If you contact support, please provide these details.

Activity IDd09fe8e9-61a1-403a-869f-4aa6985acc12
Request ID14407492-cc4a-18a3-817b-ea957db9a3b4
Correlation IDaeaf39a3-4c05-a679-7e5d-34a3b4df3ade
TimeFri Jan 18 2019 19:02:30 GMT-0800 (Pacific Standard Time)
Version13.0.7994.169
 
 
Looked at other messages on the forum but could not find anything for Oracle 12c and this issue. 
 
Any help will be appreciated ! 
 
Thanks, 
Raj 
2 REPLIES 2
Community Support Team
Community Support Team

Re: Unable to connect to Oracle 12c DB.

@dfordhiraj,

 

Please check if Oracle client has been installed.

For 32-bit versions of Power BI Desktop, use the following link to download and install the 32-bit Oracle client:

For 64-bit versions of Power BI Desktop, use the following link to download and install the 64-bit Oracle client:

 

If the Oracle client has been installed but the issue still occurs, please check if the data gateway is wrong on the server, if the data source configurations in "Manage Gateway" is correct.

 

Community Support Team _ Jimmy Tao

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

dfordhiraj Frequent Visitor
Frequent Visitor

Re: Unable to connect to Oracle 12c DB.

Thank you for the response. 

 

I am able to connect to Oracle database fine on the machine where the gateway is installed. 

 

How ? - The report is built using PowerBI Desktop in the same machine and it runs the queries fine. 

 

Also in the gateway online - I am able to connect to the same database. It does a live check and verifies the connection is successful. 

 

I see some other forum notes where folks are saying User Prinicpal Name. I don't see the button to reference User Principal name on the connection that was built ? 

 

Any thoughts ? 

 

Let me know if I can share some screenshots of our setup here. 

 

Thanks,