cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EMaguire
Frequent Visitor

UTC time in Power BI Dataflows incorrect?

I have some Power BI Dataflows which are processing data for Power BI Activity Events (in JSON file format). These contains the CreationTime for each record in UTC datetime format - for example '2022-08-05T07:31:55Z'

The 'locale' settings for the dataflow are English (United Kingdom), but the dataflows are incorrectly converting the UTC time to local time when using Table.TransformColumnTypes(PreviousQueryStep, {{"CreationTime", type datetime}}). The record above is being converted to '05/08/2022, 00:31:55'; but it should be '05/08/2022, 08:31:55' (for British Summer Time). 

When I add a column in the Dataflows Query Editor which should return the UTC time - using DateTimeZone.FixedUtcNow() - it actually returns GMT+8. In Power BI Desktop, the same function returns to the correct time (ie. GMT) 

I can use a different M function to change the datetime to the correct local timezone, but am I doing something wrong? It seems to me that this actually a 'bug' in Power BI Dataflows because it seems to think UTC is GMT+8 and not GMT?

Thanks!

Ed

 

1 ACCEPTED SOLUTION
EMaguire
Frequent Visitor

To resolve my own post/question - in case anyone else comes across similar issues and finds this thread:

We found the problem was a result of the time-zone setting on our gateway server, which for some reason was not set correctly. 

View solution in original post

3 REPLIES 3
YalanWu_test
Helper I
Helper I

Hi, @EMaguire ;

I am so glad to hear that your problem has been kindly solved, that I can you kindly mark the reply as a solution to help others having the similar issue and close the case.

 

Best Regards,

EMaguire
Frequent Visitor

To resolve my own post/question - in case anyone else comes across similar issues and finds this thread:

We found the problem was a result of the time-zone setting on our gateway server, which for some reason was not set correctly. 

EMaguire
Frequent Visitor

To update on my own post/question:

From some further testing, my issue seems to be related to our on-premises data gateway, rather than the dataflows. In dataflows which don't use the gateway I get the correct datetime/timezone. But when I use the gateway I get the same issue as above. I'm following up on this internally. 

Helpful resources

Announcements
September Update

Check it Out!

Click here to learn more about the September 2022 updates!

Power BI Dev Camp Session 26

New Date - Check it Out!

Mark your calendars and join us on Thursday, October 6 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors
Top Kudoed Authors