cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Partisan
Post Partisan

URL Filter

Has anyone noticed that the URL filter function no longer works?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

@lcasey

 

I just tested it on my side and it worked all fine for me. Could you go and check the URL format and try it again?Smiley Happy

URL = reportURL + ?filter=table/column eq 'value'

Note: The column must be of type string and neither the table name nor the column name can contain spaces.

 

Regards

View solution in original post

7 REPLIES 7
Highlighted
Community Champion
Community Champion

I have never heard of URL filter function. Can you please post the function, its syntax and how it works.

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.
Highlighted

Highlighted

Ohh.. This is called passing of a parameters to the Web.contents function in Query editor. It is still supported and This is now more powerful as you can pass the list of values, Query and/or single value to this.

Thanks & Regards,
Bhavesh

Love the Self Service BI.
Please use the 'Mark as answer' link to mark a post that answers your question. If you find a reply helpful, please remember to give Kudos.
Highlighted

Yes, Sorry, I didnt explain it correctly, but anyway, this has not been working for a few weeks now.  It is actually a service outage and I am surprised more people are not complaining that this is no longer working.

Highlighted

@lcasey

 

I just tested it on my side and it worked all fine for me. Could you go and check the URL format and try it again?Smiley Happy

URL = reportURL + ?filter=table/column eq 'value'

Note: The column must be of type string and neither the table name nor the column name can contain spaces.

 

Regards

View solution in original post

Highlighted

No It doesnt work, It may be an outage on Our tennant.  I opened a case Last week and have had no updates or information from Microsoft.

 

Here is the URL I use:  Workflow = "https://app.powerbi.com/groups/me/reports/39d1cfaa-569f-46fd-9a52-d4188135af23/ReportSection2?Filter..." & "eq" & '00-Kwiktag'[ImageTag]

 

 

 And here is How it looks when Clicked:

 

https://app.powerbi.com/groups/me/reports/39d1cfaa-569f-46fd-9a52-d4188135af23/ReportSection2?Filter... eq 'KT0000039873'

 

 

Highlighted

It IS working!!!!

 

 

Completely excellent news.  I renamed all My Datasets and removed the 00-(DatasetName)

 

So I am just using the singlename/column  eq 'MyTag'

 

Thanks for responding and making me re-check my work!!!  You helped me solve this which is real important ..

 

 

Thanks So Much!!!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors