cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fgz112
Frequent Visitor

Trouble connecting to Redshift

Hi,

 

I've created a report in Power BI Desktop with a connection to Redshift and published it to My Workspace.  I then went to Settings to configure a refresh.  Under Data Source Credentials, I get an error stating "Your datasource can't be refreshed because the credentials are invalid".  I click "Edit Credentials" and re-enter the same credentials I used to connect via Desktop.  After running for a moment, I get a message stating that there was an "error while trying to connect to the server, Permission Denied, Is the server running on host 'X' and accepting TCP/IP connections on port 'Y'?"  Any idea why this might be happening?

1 ACCEPTED SOLUTION
v-yingjl
Community Support
Community Support

Hi @fgz112 ,
Based on the error message, it is an issue with permission to access the cluster.

To connect to the cluster from a client tool outside of the network that the cluster is in, add an ingress rule. Add the rule to the cluster security group for the CIDR/IP that you are connecting from:

  • If you created your Amazon Redshift cluster in a virtual private cloud (VPC) based on Amazon VPC, add your client CIDR/IP address to the VPC security group in Amazon VPC. For more information about configuring VPC security groups for your cluster, see Managing clusters in a VPC .

  • If you created your Amazon Redshift cluster outside a VPC, add your client CIDR/IP address to the cluster security group in Amazon Redshift. For more information about configuring cluster security groups, see Amazon Redshift cluster security groups.

If you attempt to connect to the cluster from a client tool in an Amazon EC2 instance, you also add an ingress rule. In this case, add the rule to the cluster security group for the Amazon EC2 security group that is associated with the Amazon EC2 instance. For more information about configuring cluster security groups, see Amazon Redshift cluster security groups.

In some cases, you might have a layer between your client and server, such as a firewall. In these cases, make sure that the firewall accepts inbound connections over the port that you configured for your cluster.

 

If not help, you can attempt to connect once then go to File==>Options and Setting ==>Data Source Settings select the Redshift connection then click Edit Permissions Change uncheck the encryption and change the privacy level to Public

redshift.png

 

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

2 REPLIES 2
v-yingjl
Community Support
Community Support

Hi @fgz112 ,
Based on the error message, it is an issue with permission to access the cluster.

To connect to the cluster from a client tool outside of the network that the cluster is in, add an ingress rule. Add the rule to the cluster security group for the CIDR/IP that you are connecting from:

  • If you created your Amazon Redshift cluster in a virtual private cloud (VPC) based on Amazon VPC, add your client CIDR/IP address to the VPC security group in Amazon VPC. For more information about configuring VPC security groups for your cluster, see Managing clusters in a VPC .

  • If you created your Amazon Redshift cluster outside a VPC, add your client CIDR/IP address to the cluster security group in Amazon Redshift. For more information about configuring cluster security groups, see Amazon Redshift cluster security groups.

If you attempt to connect to the cluster from a client tool in an Amazon EC2 instance, you also add an ingress rule. In this case, add the rule to the cluster security group for the Amazon EC2 security group that is associated with the Amazon EC2 instance. For more information about configuring cluster security groups, see Amazon Redshift cluster security groups.

In some cases, you might have a layer between your client and server, such as a firewall. In these cases, make sure that the firewall accepts inbound connections over the port that you configured for your cluster.

 

If not help, you can attempt to connect once then go to File==>Options and Setting ==>Data Source Settings select the Redshift connection then click Edit Permissions Change uncheck the encryption and change the privacy level to Public

redshift.png

 

Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.

 

 

View solution in original post

GilbertQ
Super User II
Super User II

Hi there

Can you make sure that your Redshift server can accept connections from the Power BI Service?

I would suggest installing and configuring a Gateway in order to refresh the data from Redshift




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

MBAS on Demand

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Get Ready for Power BI Dev Camp

Microsoft named a Leader in The Forrester Wave

Microsoft received the highest score of any vendor in both the strategy and current offering categories.