cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Yggdrasill
Responsive Resident
Responsive Resident

The 'user' value of the 'EffectiveUserName' XML for Analysis property is not valid

Hi

 

I'm trying to schedule refresh on SSAS instance via Power BI service. The gateway is setup on a local machine and administrated by me john@doe.com

 

My UPN is john@doe.com but the admin on the SSAS instance is MATRIX\neo

 

I did try to Map the user name on the SSAS instance so that john@doe.com - > MATRIX\neo but that returns this error whenever I try to refresh my data in the PBI Service.

error.png

 

 

 

The gateway is green and good to go and even though I do not map my user name, it still returns this error whenever I try to refresh my data via PBI Service.

 

What am I doing wrong here ?

 

Ps. I'm not connecting directly but importing data.

 

 

6 REPLIES 6
AliSafa
Frequent Visitor

same issue here.

v-piga-msft
Resident Rockstar
Resident Rockstar

Hi @Yggdrasill

 

Have you added your data source successfully?

 

datasourcesettings3-ssas.png

 

It seems that you select the Manual user name re-mapping. You should check if you have map your username correctly?

 

For Analysis Services data sources, you can configure custom User Principal Name (UPN) rules. This will help you if your Power BI service login names do not match your local directory UPN. For example, if you sign into Power BI with john@contoso.com, but your local directory UPN is john@contoso.local, you can configure a mapping rule to have john@contoso.local passed to Analysis Services.

 

Besides, Please check if your Windows accout have Server Administrator permissions for the SSAS instance.

 

You could have a good reference of this similar thread.

 

Reference: 
Usernames with Analysis Services

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This is still not solved.

 

I'm logged in as John@doe.com but I'm mapping that to my local UPN MATRIX/neo

Still get the same error even if Matrix/neo is admin over the SSAS instance.

Having the same issue...

@mamsteroonie @Yggdrasill Did you have any luck with this?  I am also experiencing an issue here.

I've added data sources to the gateway successfully. Both as MATRIX\neo and as john@doe.com

 

The datasource is all green and good to go as well as the gateway.

 

The mapping of the usernames is correct.

 

My windows account, john@doe.com, is in fact an admin over the SSAS instance too.

 

The AD is john@doe.com and the alias is MATRIX\neo

 

I can't figure out why the username is not matching. 

 

I can refresh everything without a problem in Power BI desktop, I can access the cubes in management studio and build queries. I see that I'm an admin there as well.

 

This is so frustrating

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors