cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
fulgeru99 Frequent Visitor
Frequent Visitor

The specified culture is not supported

I created a dataset over Blob Storage and published it. The auto-refresh si giving me this error:

Data source error: The specified culture is not supported.. The exception was raised by the IDataReader interface.
Cluster URI: WABI-NORTH-EUROPE-redirect.analysis.windows.net
Activity ID: 4a9e045d-f869-4c20-9fc2-5fcc177db90b
Request ID: c2f03e9d-16ed-49a5-a713-ffbbcf872276
Time: 2017-06-21 12:03:49Z

How can we fix it?

6 REPLIES 6
fulgeru99 Frequent Visitor
Frequent Visitor

The specified culture is not supported

I created a dataset over Blob Storage and published it. The auto-refresh si giving me this error: Data source error: The specified culture is not supported.. The exception was raised by the IDataReader interface. Cluster URI: WABI-NORTH-EUROPE-redirect.analysis.windows.net Activity ID: 4a9e045d-f869-4c20-9fc2-5fcc177db90b Request ID: c2f03e9d-16ed-49a5-a713-ffbbcf872276 Time: 2017-06-21 12:03:49Z How can we fix it?
Moderator v-qiuyu-msft
Moderator

Re: The specified culture is not supported

Hi @fulgeru99,

 

Please open the report in desktop, check which kind of local set in report:

  1. File > Options and settings > Options.
  2. Under Current file, select Regional Settings.
  3. In the Locale box

q2.PNG

 

Change it to the English(US) then republish to service to see if refresh can be successful.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
fulgeru99 Frequent Visitor
Frequent Visitor

Re: The specified culture is not supported

I changed to English US, published and refresh gives the same error. What can be done?

fulgeru99 Frequent Visitor
Frequent Visitor

Re: The specified culture is not supported

I found a stupid solution: after getting Azure Blob data if I add a row filter the refresh stars to work:

#"Kept First Rows" = Table.FirstN(imports1,1000000000)

 

Come on guys, you can do better than this when exposing the refresh errors.

Moderator v-qiuyu-msft
Moderator

Re: The specified culture is not supported

Hi @fulgeru99,

 

Please do not apply the workaround to the report. Open the Fiddler with HTTPS encrypt enabled then click Refresh Now to refresh dataset until the error throws out. Please share .saz file with us. Also please share the Cluster URI, Activity ID, Request ID which listed in error message.

 

Best Regards,
Qiuyun Yu

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
AlexanderAT Regular Visitor
Regular Visitor

Re: The specified culture is not supported

This solved the problem for me - Thanks!