cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ms_powerbi
Frequent Visitor

The key didn't match any rows in the table

Hi community,

 

I have a very strange error "The key didn't match any rows in the table" when refreshing a dataset in the PowerBI webservice. The dataset refresh works fine when I do it in PowerBI Desktop.

 

I have seen similar questions where the solution was that an excel worksheet in the source was renamed. However, my only sources are dataflows and they do all work fine as well. 

 

Any ideas where I could look for an error?

 

Thanks

Martin

1 ACCEPTED SOLUTION
ms_powerbi
Frequent Visitor

This is what I received from MS and it solved the problem for me

 

As informed earlier we have reached out to our Product team and got an update form them stating that the fix for the issue you are facing would be in next 2 -3 weeks. Workaround ========================================

The workaround is to turn off the SameSite settings in the browser. Go to chrome://flags or edge://flags and search for SameSite, disable the 2 (edge) or 3 (chrome) features that show up. Restart and it will work. Further we request you to try the above workaround and please let us know if you are still facing any issues. We apologies for the inconvenience caused. I look forward to hearing from you soon!

View solution in original post

34 REPLIES 34
ncanderson
Frequent Visitor

Just got off a Teams meeting with Support and they have the debugging team working to find the root cause of the issue. They recommended for an immediate solution to just not use Dataflows for ones that are erroring.

It seems that the debugging team has found and resolved the error. For me at least, the dataset refreshes work again

 Ok, sorry. It refreshed once and now we are back to the original problem...

Great to hear @ncanderson !

 

Do you happen to have any "Navigation" steps in your Dataflow that is creating the Dataset? I read in another thread, that removing this step will solve the issue, but if I did that it would no longer allow my REST API to retrieve to properly create a table within the entity...

kryherd
Frequent Visitor

We are having the same issue as well. Started a few days ago (2/10/20), only an issue for datasets that are on the web. Refreshes work on Desktop.

Has anyone contacted PowerBI support yet? Last time I had this issue, they were unable to help me and asked me to rebuild my dataflow entirely....

ncanderson
Frequent Visitor

I am having this issue as well.. Using dataflows as the data source in the dataset and the error is happening when the dataset is refreshing in the service. It refreshes fine when I have the PBI Desktop file open and manually refresh, but errors when refreshing online. 

 

Below are the message received for one of the datasets.

 

Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Message: The key didn't match any rows in the table. Table: INVTRANS_NF.
Cluster URI: WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID: d446c382-17eb-4d15-800b-ac707fe2a260
Request ID: 7a39b30d-1ee9-33b5-08fa-fe42b73199f6
Time: 2020-02-12 03:13:48Z

I have raised a support ticket with Microsoft. If I get any useful information I will report it here but I would encourage anybody else reading this who is experiencing the problem to raise it with support as well.

Same issue here today!

Data source error:The key didn't match any rows in the table The exception was raised by the IDbCommand interface. Table: Time Cards.
Cluster URI:WABI-CANADA-CENTRAL-redirect.analysis.windows.net
Alex_Rajkov
Advocate II
Advocate II

I have this, too. Since yesterday (while refreshing dataflows).

Microsoft support aknowledged it is a bug.

The support page should state that, but isn't...

@Alex_RajkovTo clarify, are you experiencing the error when refreshing a dataflow or when refreshing a dataset that is sourced from a dataflow?

refreshing a dataflow

@Alex_RajkovOK, slightly different to myself and the original poster then - my dataflows are continuing to refresh ok, it is just refreshing datasets sourced from one of them through Power BI Web that results in the error.

Mark_Tracy
Frequent Visitor

I am having the exact same issue, same circumstances, today.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!