cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Re: The key didn't match any rows in the table

SameSite is client-side and browser-specific. How would this at all affect a server-side data connection issue from PowerBI?

Highlighted
Helper II
Helper II

Re: The key didn't match any rows in the table

I just started having this issue. Does anyone have a solution?

Highlighted
Frequent Visitor

Re: The key didn't match any rows in the table

I have the same problem, that is, when I refresh the dataset that is connected to the dataflow, I have the same error.
However:
My case is a little different, because I have two different tables in two different dataflows ...
I change the datafow and the entity via Parameters ...

Dataflows are successfully refreh
Dataset is refreshed with error.

I did a test using the same dataflow for the two different tables and then I was successful !!!😎
But I can't believe I can't use two different datafows via parameters ...🙄

Highlighted
Regular Visitor

Re: The key didn't match any rows in the table

Hi everyone! i'm experiencing the same error but i just refresh the dataset. No dataflows or gateway.Pls help!is there any solution to this?

Highlighted
Frequent Visitor

Re: The key didn't match any rows in the table - I have it differently

Hi community,

 

Newbie here.  I've checked the thread and I think I am getting the error for an entirely different reason, probably related to my limited skill in M.   Removing my (system generated) Navigation step didn't work - it removed the label for the mail directory 🙂 .  I am not working with streams, nor am I working with database software or Excel.  I have certainly tried the several approaches to refreshing my source data with no success.

 

My process is to import all the e-mails in a subfolder and then process each one.  The body of each e-mail is text within which are eight parameters I want that I find be text manipulation after creating a table with each text line being a row.  This all works fine for the single case.  As soon as I try to process all the e-mails my code fails.  The text processing is done in a function I wrote called "ExtractSalesForce".  (This is an e-mail, I don't want to fetch from SalesForce directly.)

 

The screenshot of the error message shows the top of the text in the body of the e-mail.  The code fragment shows successful use of my function on a single e-mail, and the statement causing a problem.

 

The e-mails end up in the table "RemovedDuplicates".  It has one column named "Body.TextBody".  The 'Text.Replace' is to remove commas so they don't create a new record.  I change them to a hyphen so I can text match to find a parameter.  As commented, QueryTable2 has the desired information.  I then want to add a column to "RemovedDuplicates" that has a record in it generated by my function "ExtractSalesForce" (the eight parameters I want).  This is then expanded into the eight parameters (one per column) and the originating column deleted.

 

Here is the error text:

 

image001 (1).jpg

 

 

 

 

 

 

 

 

 

 

And the code fragment is:

 

    QueryTable2 = Table.FromRecords(ExtractSalesForce(List.Transform(Record.ToList(RemovedDuplicates{1}),

                        each Text.Replace(_,","," -"))  )  ),

/* this code works - QueryTable2 has the eight parameters of the second e-mail

*/

    LoopOverQueries = Table.AddColumn(RemovedDuplicates,"NewRowQueryElements", each

                         ExtractSalesForce(List.Transform(Record.ToList([Body.TextBody]),

                        each Text.Replace([Body.TextBody],","," -"))  ) ),

 

I would greatly appreciate any suggestions to get this to work, including better code.

 

Michael J.

Helpful resources

Announcements

August Community Highlights

Check out a full recap of the month!

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors