cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Justair07 Resolver I
Resolver I

The credentials provided for the AzureBlobs source are invalid

Hello,

I have an AzureBlob storage account for images that I want to view in Power BI. I created my report in Power BI Desktop with the same credentials I saved and Published my report to in an App Workspace. From the Desktop, the data refreshes great. Everything on the Desktop works great. In the Workspace, I cannot succesfully perform a refresh without receiving the error in the picture below. I'm not using a Gateway since it is optional. It was working about 2 weeks ago and stopped working for no apperant reason. This is extremly frustrating and any help is very much appreciated.

 

Annotation 2020-02-18 115423.png

 

I'm using OAuth2 "Authenication method" and the privacy level is set to "Organizational"

 

I'm then prompted to login in, this is where I provide the same credentials I use for the AzureBlob Storage account. The sign in is succesful. I go back to the dataset screen to try and refresh... same error 😞

4 REPLIES 4
Community Support
Community Support

Re: The credentials provided for the AzureBlobs source are invalid

hi  @Justair07 

Please check your Azure Blob storage firewall configuration, the firewall setting of the azure storage account need to whitelist the IP address of the Power BI Service. If these IP address are not whitelisted, the access will not succeed.

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Justair07 Resolver I
Resolver I

Re: The credentials provided for the AzureBlobs source are invalid

@v-lili6-msft thank you for the reply. As you can see from the picture, my home region is West US:

Capture.JPG

But from the download you shared with me of the region IP's, how do I know which one to use:

Capture1.JPG

Justair07 Resolver I
Resolver I

Re: The credentials provided for the AzureBlobs source are invalid

@v-lili6-msft It took a long time but I tried 100 different IP's but Power BI Service will still not refresh without the credentials error. There must be something else I'm missing. It would take me a year to try all the IP's by manually entering them, see picture:

Capture3.JPG

phetzel1
Frequent Visitor

Re: The credentials provided for the AzureBlobs source are invalid

@v-lili6-msft Any further guidance here? There is no reference to Power BI in the list of IPs that you recommended. Which IPs are necessary to whitelist? Additionally, if I am in US East 2, there are around 300 IP ranges to whitelist. There is a maximum of 100 IP rules possible for a Storage firewall.

Helpful resources

Announcements
Announcing the New Spanish Forum

Announcing the New Spanish Forum

Do you need help in Spanish? Check out our new Spanish community section.

MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

‘Better Together’ Integration Forum Launch

‘Better Together’ Integration Forum Launch

We've launched a how-to forum where you can learn about how Power BI integrates with other Power Platform products.