cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
kthejoker
Advisor

Streaming Analytics DataSet not showing up in PowerBI

Hi,

 

I've created a Streaming Analytics job using an event hub.

 

I've verified the Event Hub is working and receiving data.

 

I've set the ASA query to

 

 

SELECT
    SUM(Duration) AS Duration, ApplicationName, DatabaseName, ServerName, NTCanonicalUserName
INTO
    output2
FROM
    input1 TIMESTAMP BY EndTime
GROUP BY
ApplicationName, DatabaseName, ServerName, NTCanonicalUserName, TumblingWindow(second,60)

 

I've set output2 to point to PowerBI using the same authorized user as my Azure portal, gave it a DataSet and Table name, pointed it to My Workspace.

 

Testing the output and input both return a success in the portal.

The job starts successfully.

 

But when I go to PowerBI the dataset doesn't appear. 

 

I'm sure something isn't configured correctly, but there's basically no logs or documentaiton to check to see what's happening under the hood for me to troubleshoot.

 

What should I be checking for?

6 REPLIES 6
cnwakanma Frequent Visitor
Frequent Visitor

Re: Streaming Analytics DataSet not showing up in PowerBI

Two suggestions:

     1. Send the same output to a blob storage account in CSV format and view file to verify your query is producing output

     2. I've had encouneterd a similr error when trying to use "TIMESTAMP BY". Try removing that from your query to see if the dataset shows up in power bi, if so, you may want to add "EndTime" to list of fields in your select query.

 

I hope this helps

 

ephaimm New Member
New Member

Re: Streaming Analytics DataSet not showing up in PowerBI

I have the same issue. I have checked that the data is coming through correctly in blog storage. I have added an "EndTime" column, but the dataset from stream analytics still does not appear in Power BI

ttrail Frequent Visitor
Frequent Visitor

Re: Streaming Analytics DataSet not showing up in PowerBI

I have a similar issue.  My dataset shows up under "Streaming datasets" but I'm unable to create reports, tiles or complete a Q&A because all of the fields appear to have no data.  Interestingly enough, if I select the tile, choose edit and look at the Technical Details, the next refresh isn't until 9999.  Does that mean it'll never refresh to get any actual data?

 

tileRefresh.JPG

VinayN Frequent Visitor
Frequent Visitor

Re: Streaming Analytics DataSet not showing up in PowerBI

Hello everyone,

 

I am facing a similar issue. My query is quite simple:

SELECT
*
INTO
[OutputJob]
FROM
[InputJob]

 

Input Job is receiving input data from Event Hub and is tested successfully.

 

Output Job is pointed to Power BI, creating a new DataSet and a new Table. But, I do not see the new DataSet and the Table in the Power BI under my selected Work Space. Please provide me some inputs.

 

Also, as per the link:

http://community.powerbi.com/t5/Integrations-with-Files-and/Dataset-is-not-created-from-azure-stream...

 

I have mailed my Azure Subscription ID and the region i want to see the data in, to ASAtoPBIStreaming@microsoft.com

But, i haven't heard back anything from them as well.

 

Thanks in advance!

VinayN Frequent Visitor
Frequent Visitor

Re: Streaming Analytics DataSet not showing up in PowerBI

Hello everyone,

I am facing a similar issue. My query is quite simple:
SELECT
*
INTO
[OutputJob]
FROM
[InputJob]

Input Job is receiving input data from Event Hub and is tested successfully.

Output Job is pointed to Power BI, creating a new DataSet and a new Table. But, I do not see the new DataSet and the Table in the Power BI under my selected Work Space. Please provide me some inputs.

Also, as per the link:
http://community.powerbi.com/t5/Integrations-with-Files-and/Dataset-is-not-created-from-azure-stream...

I have mailed my Azure Subscription ID and the region i want to see the data in, to ASAtoPBIStreaming@microsoft.com
But, i haven't heard back anything from them as well.

Thanks in advance!

punamyadav Frequent Visitor
Frequent Visitor

Re: Streaming Analytics DataSet not showing up in PowerBI

Hi, did you get this issue resolved? I am having the same issue.