cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KD_PBI_DA100
Advocate II
Advocate II

Slicer dropdown menu appears offset in Service environment

Morning, I am facing this very odd issue with slicers. In PBI Desktop, the slicer dropdown menu appears normally. However, if I want to pick items from dropdown in the published report the list of items appears offset from the slicer itself. please see attached image: 

kevindmonte_0-1631004971114.png

 

And if I view the published report in full screen mode, the dropdown menu simply disappears (possibly offsetting extreme right, out of bounds of the screen). 

Has anyone encountered similar issue and if yes, what was the fix? 

 

1 ACCEPTED SOLUTION
v-yangliu-msft
Community Support
Community Support

Hi all,

This is a known issue (ICM#: 260227233). Power BI Product Team attach great importance and update on Power BI Support Page.

 

Root Cause:

This is a regression in the Chromium build, Bug# 1247858, and is impacting Edge and Chrome V93 web browsers.

 

Workaround:

A zoom setting of anything other than 100% forces the browser to behave normally again. 90% or 110% zoom works fine.

 

Please be patient and if there are any updates, I will post them here.

 

Best Regards,

Liu Yang

View solution in original post

30 REPLIES 30
v-yangliu-msft
Community Support
Community Support

Hi all,

 

According to the latest news:

Chromium v94 is released normally, you can upgrade to v94, see if the issue is back to normal.

Thank you very much.

 

Best Regards,

Liu Yang

I upgraded Chrome. The issue is fixed on power bi report server. Thank you.

All good on my side.

v-yangliu-msft
Community Support
Community Support

Hi all,

 

Regarding the issue in Power BI Report Server, Product Team is fixing. This will take some time to take effect. Please be patient.

In addition, PBIRS Sep 2021 and Chromium v94 will also be released soon.

I'll post here if there are any updates.

 

Best Regards,

Liu Yang

v-yangliu-msft
Community Support
Community Support

Hi all,

This is a known issue (ICM#: 260227233). Power BI Product Team attach great importance and update on Power BI Support Page.

 

Root Cause:

This is a regression in the Chromium build, Bug# 1247858, and is impacting Edge and Chrome V93 web browsers.

 

Workaround:

A zoom setting of anything other than 100% forces the browser to behave normally again. 90% or 110% zoom works fine.

 

Please be patient and if there are any updates, I will post them here.

 

Best Regards,

Liu Yang

View solution in original post

I use the report published on the Report Server and it's still having a problem.

Have you tried to decrease Chrome's zoom level from 100% to 90%? That fixed the issue for me.

Yes, I've tried it this way, and it works. However, report users have been complaining about having to fix the zoom, they are demanding a definitive solution.

Changing the zoom affects the view of other systems used by users and they would have to keep switching.

As they should indeed. And this is why it shouldn't be our responsibility, the users, to try to find a fix, no matter how temporary and no matter how urgent because of a real life sales event the next bloody day (as one user put it).  If Google or Microsoft drop the ball, it's theirs to pick up. It's a question of principles, nothing more, nothing less. But I know, if that were the case, the Windows blue screen of death would have been fixed eons ago, for example. This is the world we live in apparently. 😉

@v-yangliu-msft Looks like this was resolved in the Power BI Service but I assume the issue would continue to remain in Power BI Report Server until the chromium level issue gets fixed and we get browser updates. Is that correct?

CalebBlanton
Advocate II
Advocate II

Some of you remind me of Tom Smykowski from Office Space: It's a "Jump to Conclusions Mat."  🙂

 

This is now on the "Awareness" section of the top-level PBI support site, and the root issue lies in Chromium bug # 1247858 which was introduced in the latest v93 update.  So if you want this fixed, focus your efforts on convincing that development community to prioritize a v93 patch versus a v94 fix (this is already fixed in BETA I believe).

 

P.S. For those of you who scoff with disdain at the provided Browser Zoom 90/110 workaround (thanks Isaac!), apparently you don't have a sales team showing off analytics tomorrow that are in desperate need of a viable workaround until fixed.  Should have, could have, would have all have no place in the real world.  Carry on.

Dongshan
New Member

Same here, seems all Chromium based browser are effected.

CalebBlanton
Advocate II
Advocate II

All reports, old and new, seem affected by this issue - we also have a "maximize" button to go full screen and when we do that, without the Zoom hack the dropdowns completely disappear!  @isaacc Is there a defect somewhere reported, either on the Power BI side or on Chromium that you know if?  I'd like to track this more closely as we have a lot of internal and external stakeholders complaining.  Started happening a few days ago. 

StormBreaker18
New Member

It's seems to be an issue with Chrome, and Chromium based browser like Edge. All my reports published on PowerBI Report Server (and no updates were installed) as of yesterday started to have this offset. Installed firefox and it renders just fine on that browser.

JAW
Regular Visitor

Same issue here. Slicer dropdown appears to be offset at 100% zoom scale unless the window is resizerd to a very specific size (depending on the native width of the report versus the display monitor).

 

Interestingly it appeared to offset to the right when the browser is maximised and to the left when in a smaller window. So I played around resizing the window for a bit and found that changing the horizontal window size could move the menu back to the intended location.

isaacc
Microsoft
Microsoft

As a workaround just change the browser zoom to anything different than 100%. It may be 90% or 110% and it makes the slicer render properly. 

 

See the following:

 

Zoom set to 100%:

isaacc_0-1631120920054.png

 

Zoom set to 90%

 

isaacc_1-1631120991960.png

 

 

 

Indeed!  Works like a charm. However, I resent that the community had to find a temporary solution. Let it be know, this is my official protest. 😉

Unfortunately this didn't solve the issue for me.

I had to change the view of the report from fit to width to actual size.

 

It would be great if this could be investigated further as our default upload is either fit to page or fit to width.

Neustupa2001
Frequent Visitor

I'm having the same issue on all dropdown slicers as well.  The only three workarounds that I've found so far are the two above(change browser zoom level and fit to actual size).  The third one is to not maximize the browser window as this only happens when maximized.

Nope. It happens for me whether maximized or not.  And honestly, I got better things to do than waste my time and thus, company time, on an issue Microsoft is responsible for.  

 

Or perhaps I am being a bit hasty on laying the blame at MS's doorstep. Perhaps it is the Chrome engine and god knows what atrocities the Javascript VM is committing. In which case, I am looking at you, Google. Let the blame game begin!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

November Power BI Update 768x460.png

Check it Out!

Click here to read more about the November 2021 Updates!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.