cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PradeepT Frequent Visitor
Frequent Visitor

Shared Dashboards are not working as reports inside are not responsive

Hello Team,

NEED URGENT HELP!!!!

We have been facing a strange issue when we publish the dashboard with Internal & External users. Users get an email with a link after the dashboard is shared with multiple reports under it, where the user can open the dashboard link and find the reports are not responsive(Does not open after clicking). The issue exists only when we share the dashboard. 
(When an individual report is shared instead of a dashboard, it works and people can access the report with no issues.)

The issue exists for multiple people in the organization where sharing of dashboard internally does not work either which is weird.
We would need your help on how to resolve this issue.

PS : All the users have PowerBi Pro License. 


Scenario 1 - Admin(Reports/Workspace owner) creates a workspace and adds 4 different reports.
                    Admin creates a dashboard and has 4 reports under it where each report is linked to their respective Tiles (Text Box).
                    Admin shares the dashboard with users individually to thier organizational ID's.
                    User gets an email invitation with a link of the dashboard. User has a pro license and opens the link and the                                        dashboard opens with reports tiles under it.
                    User clicks on the report tile to open. Nothing Happens!!! Tries with another report, Nothing Happens!!

The issue occurs for both external users as well as internal users.
 We have tried creating a workspace with the old one and the new improved workspaces and we still face issues.

We have tried creating multiple workspaces and the issue is the same.

The data is loaded from Redshift and scheduled refresh is working well and the data sets are upto date.

Sharing of individual reports, we have no issues. /

Sharing of dashboards is the problem and it exists for multiple people in the organization.

We have checked with users who are facing issues, every user is following the similar steps as above and the issue exists.

 

Our Findings,

We noticed that when we share the dashboard to a user, we see the user names in the Access list where we can know if the user has Read/write access. But when we go to dataset and check under "Manage Permissions", there are no names of users in the list. We have manually added the users name and tried sharing the report and it does not work either.
The direct links also failed when shared with users. 

 

We also noticed that "RELATED CONTENT" shows empty for a DASHBOARD where we have 2 reports under it. Please check the pictures below.

Dashboard Error 1.png

 

Dashboard Error 2.png

 

 

Please provide us a solution for this as we are not sure why this is causing an issue and this is causing ahuge delay in our work.
There are other issues linked where we can post once we have a work around and try.(To be discussed later)

6 REPLIES 6
PradeepT Frequent Visitor
Frequent Visitor

Shared Dashboards are not working as reports inside are not responsive

Hello Team,

NEED URGENT HELP!!!!

We have been facing a strange issue when we publish the dashboard with Internal & External users. Users get an email with a link after the dashboard is shared with multiple reports under it, where the user can open the dashboard link and find the reports are not responsive(Does not open after clicking). The issue exists only when we share the dashboard. 
(When an individual report is shared instead of a dashboard, it works and people can access the report with no issues.)

The issue exists for multiple people in the organization where sharing of dashboard internally does not work either which is weird.
We would need your help on how to resolve this issue.

PS : All the users have PowerBi Pro License. 


Scenario 1 - Admin(Reports/Workspace owner) creates a workspace and adds 4 different reports.
                    Admin creates a dashboard and has 4 reports under it where each report is linked to their respective Tiles (Text Box).
                    Admin shares the dashboard with users individually to thier organizational ID's.
                    User gets an email invitation with a link of the dashboard. User has a pro license and opens the link and the                                        dashboard opens with reports tiles under it.
                    User clicks on the report tile to open. Nothing Happens!!! Tries with another report, Nothing Happens!!

The issue occurs for both external users as well as internal users.
 We have tried creating a workspace with the old one and the new improved workspaces and we still face issues.

We have tried creating multiple workspaces and the issue is the same.

The data is loaded from Redshift and scheduled refresh is working well and the data sets are upto date.

Sharing of individual reports, we have no issues. /

Sharing of dashboards is the problem and it exists for multiple people in the organization.

We have checked with users who are facing issues, every user is following the similar steps as above and the issue exists.

 

Our Findings,

We noticed that when we share the dashboard to a user, we see the user names in the Access list where we can know if the user has Read/write access. But when we go to dataset and check under "Manage Permissions", there are no names of users in the list. We have manually added the users name and tried sharing the report and it does not work either.
The direct links also failed when shared with users. 

 

We also noticed that "RELATED CONTENT" shows empty for a DASHBOARD where we have 2 reports under it. Please check the pictures below.

 

 Dashboard Error 1.pngDashboard Error 2.pngRelated Content is Missing

 

Please provide us a solution for this as we are not sure why this is causing an issue and this is causing ahuge delay in our work.
There are other issues linked where we can post once we have a work around and try.(To be discussed later)

 

Highlighted
Super User
Super User

Re: Shared Dashboards are not working as reports inside are not responsive

Hi @PradeepT

 

It would appear to me when you are clicking on the related content that it is not linked to any dashboard.


I would suggest editing the details and using the set Custom Link, then link that through to your dashboard?


Did I answer your question? Mark my post as a solution!

"Proud to be a Datanaut!"


Power BI Blog
Community Support Team
Community Support Team

Re: Shared Dashboards are not working as reports inside are not responsive

Hi @PradeepT,

 

According to your description, it seems like you create a dashboard with contents from different records and you are try to use it as navigate dashboard to bring viewers to different reports, right?

 

If this is a case, have you try to click on '...' icon to choose 'go to report' option to navigate to correspond report?

 

In addition, you can also try to use GilbertQ 's suggestion to set up custom links to redirect to report side if they have enough permission to view report contents.

 

Regards,
Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
PradeepT Frequent Visitor
Frequent Visitor

Re: Shared Dashboards are not working as reports inside are not responsive

The Main intention of this dashboard is that we have 4 different reports and we want this in a single dashboard as sharing it to users where users have all the reports at one place. 

We click on "Create" and select "Dashboard" to create a new Dashboard and then add tiles inside the dashboard for each report.

We have 4 reports which we want it in the above dashboard. The steps we use to create a tile is below,

TILE 1 : I click on "Add Tile" > Choose "Select TEXT BOX" source and fill in the details(Title name) and the tick the check box where the custom link is set to the report (Link type shown below). Report 1 is selected here.

In the same way we create three more tile are created and reports are linked. So Tile 2 > Report 2, Tile 3 > Report 3, Tile 4 > Report 4.

We have 4 different reports created and published from PowerBi Desktop to this Workspace. Each report is unique in thier build. 
Dashboard Error 3.pngDashboard Error 4.png

We have linked the reports as above and the dashboard has been shared with users, But when the user gets the email with a link, they can open the dashboard and clicking on the Tile, the reports will not open. Also when we click on the Elipses (...) and try opening the hyperlink, it will not work either.

 

Based on the Suggestions provided by @GilbertQ and @v-shex-msft
@GilbertQI had linked all the reports before. This happens when we create a new dashboard and no problems with the one that powerBi automatically creates once you upload the files/reports.

 

@v-shex-msftI will try checking your option once more and also would try the below workaround,

!!!!     I will try placing the report link directly from the web after opening it from the reports and will place the same in the Tile linking where I will set the Link Type to EXTERNAL LINK and will see if this works.
Example Below: 
https://app.powerbi.com/groups/XXXXXXXX/reports/YYYYY/ReportSection?ctid=ZZZZZZZZ

 

Also Note that: When a New dashboard is created manually, Q&A gets disabled and when tired switching it On, an error message appears that it cannot be for the dataset.
"There are no Roles / RLS created for the reports."

Community Support Team
Community Support Team

Re: Shared Dashboards are not working as reports inside are not responsive

HI @PradeepT,

 

>>"There are no Roles / RLS created for the reports."

It sounds like your contets has set up RLS. If this is a case, you need to assign role to users on service who will view your reports.

Row-level security (RLS) with Power BI

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
PradeepT Frequent Visitor
Frequent Visitor

Re: Shared Dashboards are not working as reports inside are not responsive

Hello @v-shex-msft,

 

There is no RLS set  or any roles assigned. I suspect there is a problem when we create a dashboard manually by creating it and linking a report in a Tile. 

I would brief my explantion on our findings as we are yet trying to understand the security settings from our clients environment and also I have few questions regarding Manually creating a dashboard where this problem occurs. Please give me sometime as I will get back to you with more information on this.

Helpful resources

Announcements
Back to School Contest

Back to School Contest

Engage and empower students with Power BI!

MBAS Gallery

Watch Sessions On Demand!

Continue your learning in our online communities.

Summit Australia 2019

Summit Australia 2019

Travel to Melbourne and network with thousands of peers!

PBI Community Highlights

PBI Community Highlights

Check out what's new in the Power BI Community!

Top Ideas
Users Online
Currently online: 235 members 2,076 guests
Please welcome our newest community members: