cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
caustin Frequent Visitor
Frequent Visitor

Server for Gateway is .net 4.7 supported?

Hello,

 

My shop will be pushing out .net 4.7 to the server where the on-premise gateway resides.

We did set it up with the .net 4.5 as stated in the documentation.

 

Is there any issue moving to .net 4.7 that anyone is aware of?

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-qiuyu-msft
Moderator

Re: Server for Gateway is .net 4.7 supported?

Hi @caustin,

 

You can see System Requirements from on-premise data gateway download page, it mentions .Net Framework 4.5.2 or greater is supported.

 

So you can run the data gateway in .Net version 4.7. Please make sure you are using the latest version of the gateway. Currently the latest version is 14.16.6423.3 released on 8/16/2017, you can download from the above link.

 

Best Regards,
QiuyunYu

 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Super User
Super User

Re: Server for Gateway is .net 4.7 supported?

@caustin 4.5 is the minumum requirement. While not an "official response" I have multiple machines with higher .Net frameworks (4.6) and there are no issues.

Near SE WI? Join our PUG Milwaukee Brew City PUG
caustin Frequent Visitor
Frequent Visitor

Re: Server for Gateway is .net 4.7 supported?

@Seth_C_Bauer Thank you.  I have searched for an "official" something for beyond 4.5 but came up with nothing.  Our sysadmin team wanted some more research done prior to the September upgrade on our servers so I appreciate you posting your experience.

Moderator v-qiuyu-msft
Moderator

Re: Server for Gateway is .net 4.7 supported?

Hi @caustin,

 

You can see System Requirements from on-premise data gateway download page, it mentions .Net Framework 4.5.2 or greater is supported.

 

So you can run the data gateway in .Net version 4.7. Please make sure you are using the latest version of the gateway. Currently the latest version is 14.16.6423.3 released on 8/16/2017, you can download from the above link.

 

Best Regards,
QiuyunYu

 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
caustin Frequent Visitor
Frequent Visitor

Re: Server for Gateway is .net 4.7 supported?

Thank you so much @v-qiuyu-msft !