cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TonyQPC Frequent Visitor
Frequent Visitor

Script Error when logging in via Enterpise Gateway Wizard

Hi All,

 

I've installed Enterprise Gateway, to enable publishing of Dashboards and it appears to have installed OK. Once installed, it tells me I need to sign in to Power BI, to configure the gateway. When I click on the "Sign in to Power BI" button, I get this error;

 

 Capture.GIF

 

Regardless of what I then click (Yes, No, or the X at the top to close), nothing happens, other than this small window closes, which takes me to this;

Capture2.GIF

 

The email address in that window wasn't typed in by me at any point, so must have been picked up from Power BI, I assume. Note that the apostrophe in my name (which does belong in the email address) is replaced by ' (I'm not sure if that's relevant). Again, regardless of what I do, nothing happens, so my only real option is to close this window also (the ellipses are not clickable, nor is the blue circular icon on the left), which takes me back to the start of the wizard again, where I tried to sign in to Power BI in the first place;

 

 

4 REPLIES 4
Power BI Team dimazaid
Power BI Team

Re: Script Error when logging in via Enterpise Gateway Wizard

hi @TonyQPC,
First of all, the personal Gateway will always pick up the user currently signed in to Windows. That's why it's probably taking you back to the same account all the time.
For the error you're seeing, what OS and IE version do you have on this machine?

TonyQPC Frequent Visitor
Frequent Visitor

Re: Script Error when logging in via Enterpise Gateway Wizard

Hi @dimazaid

 

Thank you for your response.

 

Just to note, this is Enterprise Gateway, rather than Personal (I'm not sure how much difference that makes with regards to the problem).

 

The OS is Windows 7 Professional, Service Pack 1

The version of IE installed is 11.0.9600.18314, Update versions: 11.0.31  (I never use IE anyway, I use Chrome).

 

Thank you

Tony

Microsoft dtorres
Microsoft

Re: Script Error when logging in via Enterpise Gateway Wizard

Hi Tony,

We found the root cause, it is an issue resolved by a security update on IE. Please check this link, get the IE version installed on server (even if you're not using our browser) and download the fix according to the version:

https://support.microsoft.com/en-us/kb/3154070

 

You will need to restart your server or PC and try PBI Enterprise Gateway installation again.

This should resolve the issue

 

Daniel Torres

MSFT

TonyQPC Frequent Visitor
Frequent Visitor

Re: Script Error when logging in via Enterpise Gateway Wizard

Hi Daniel,

 

Thank you for your response.

 

I followed the link you provided and downloaded the relevant update. However, when I tried to run it, I got a message saying it's already installed. I re-booted anyway, just in case, but the problem is still there.

 

Any other advice would be much appreciated.

 

Thank you

Tony

Helpful resources

Announcements
New Kudos Received Badges Coming

New Kudos Received Badges Coming

Kudos to you if you earned one of these! Check your inbox for a notification.

Microsoft Implementation for Communities Wins Award

Microsoft Implementation for Communities Wins Award

Learn about the award-winning innovation that was implemented across Microsoft’s Business Applications Communities.

Power Platform World Tour

Power Platform World Tour

Find out where you can attend!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (1,204)