cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Scheduled refresh not working properly

Hi there 

 

I need your help with scheduled refresh 😥

 

I used to use the personal gateway to refresh the report with local SQL sever on daily basis and it works successuly with the 'Scheduled refresh'. However, the report couldn't be refreshed after I changed the data source to Azure online database. 

 

I have checked the Data Source Credentials, it looks fine but I couldn't see the 'Scheduled refresh' option from Setting page and instead there is an option for 'Scheduled cache refresh', I selected the report to be refreshed daily and I didn't receive any error/warning message.

 

Snipaste_2020-08-04_14-27-40.png

 

 

 

 

 

 

 

 

 

 

the status shows me 'Completed' from the refresh history but actually the data wasn't refreshed 

 

Snipaste_2020-08-04_14-36-01.png

 

 

 

 

 

 

 

Much appreciated if anyone can help me out with this refresh setup 😊

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User IV
Super User IV

Re: Scheduled refresh not working properly

@janet_05 

 

I could see that your connection is DirectQuery. Since you are using DirectQuery mode, you don't need to refresh the dataset. It will always bring the latest data from the source itself. If you want to change DirectQuery into Import mode, you have to change that in PowerBI desktop and republish it. Then you will get an option for scheduled refresh.

 

https://docs.microsoft.com/en-us/power-bi/connect-data/desktop-use-directquery

https://www.cittabase.com/power-bi-tips-import-vs-direct-query/

https://community.powerbi.com/t5/Desktop/How-to-change-direct-query-to-import-query/td-p/100996

Did I answer your question? Mark my post as a solution!
Appreciate with a kudos
🙂




Regards,
Nandu Krishna

Did I answer your question? Mark my post as a solution!
Appreciate with a kudos 👍

Proud to be a Super User!

View solution in original post

1 REPLY 1
Highlighted
Super User IV
Super User IV

Re: Scheduled refresh not working properly

@janet_05 

 

I could see that your connection is DirectQuery. Since you are using DirectQuery mode, you don't need to refresh the dataset. It will always bring the latest data from the source itself. If you want to change DirectQuery into Import mode, you have to change that in PowerBI desktop and republish it. Then you will get an option for scheduled refresh.

 

https://docs.microsoft.com/en-us/power-bi/connect-data/desktop-use-directquery

https://www.cittabase.com/power-bi-tips-import-vs-direct-query/

https://community.powerbi.com/t5/Desktop/How-to-change-direct-query-to-import-query/td-p/100996

Did I answer your question? Mark my post as a solution!
Appreciate with a kudos
🙂




Regards,
Nandu Krishna

Did I answer your question? Mark my post as a solution!
Appreciate with a kudos 👍

Proud to be a Super User!

View solution in original post

Helpful resources

Announcements
Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

Don't miss the Power BI Dev Camp this week!

August Community Highlights

Check out a full recap of the month!

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power BI

Join us for an in-depth look at the new Power BI features and capabilities at the free Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors