cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ansa_naz Member
Member

Scheduled refresh always times out at the same time every day?

I have set up scheduled refresh on multiple datasets. For some reason, the scheduled refresh set for around 0900 every day always times out. Unsure how to look into this further or how to investigate. The other scheduled refreshes during the day all succeed. Any suggestions?

 

Edit - I should add that the data source is SQL Server views, created specifically for Power BI to only bring in data that is needed. Also, there are very few datasets with more than just the navigation step in the Query Editor in PBI. There are a couple of datasets with one or two steps added

1 ACCEPTED SOLUTION

Accepted Solutions
ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

I rechecked the firewall requirements, updated firewall rules, and it all seems to be working well now. I went to below:

 

https://docs.microsoft.com/en-us/power-bi/service-gateway-onprem

 

Went through the 'Ports' and 'Enabling Outbound Azure Connections' sections, made sure everyting was in line with those requirements in particular, and now all fine

8 REPLIES 8
nirvana_moksh Established Member
Established Member

Re: Scheduled refresh always times out at the same time every day?

@ansa_naz  - increase the command time out which should help1211.PNG

ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

Hi is it possible to do this in the Query Editor now, after all datasets have been imported from SQL Server already? As I cannot see a way to reach the window you have highlighted below without reimporting every dataset again

 

Also, this issue only affects the scheduled refresh at 0900, but not any of the others throughout the day (data updates every two hours).

nirvana_moksh Established Member
Established Member

Re: Scheduled refresh always times out at the same time every day?

@ansa_naz - You can reach that window by clicking on the gear option next to 'Source' which is the first step or the step wherein data connection is defined. You can alternatively add, CommandTimeout=#duration(0, 1, 0, 0) in the end and close the statement out in the Advanced Editor. Lastly, there might be conflicting refreshes scheduled for  0900 from PBI side or most likely the datasets you are trying to access take way longer than usual during that time around, so check for that from a SQL stand point of view too.

ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

Cheers will try this and see what happens

ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

I just havd the morning refresh fail again. I even changed the refresh times, but now the 1000AM refresh has failed with below error:

 

Your data gateway is offline or couldn't be reached.

 

However the gateway is obviously still online as the scheduled data refresh before 1000am still worked. And I imagine the ones after will work too. Anything else I can do?

Community Support Team
Community Support Team

Re: Scheduled refresh always times out at the same time every day?

Hi @ansa_naz,

 

Please check your gateway service on 'system -> services' to see if it stop running.

9.png

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin Sheng
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.



For learning resources/Release notes, please visit: | |
Highlighted
ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

The service is running, and has been the whole ay today. But I am still getting these errors today too

ansa_naz Member
Member

Re: Scheduled refresh always times out at the same time every day?

I rechecked the firewall requirements, updated firewall rules, and it all seems to be working well now. I went to below:

 

https://docs.microsoft.com/en-us/power-bi/service-gateway-onprem

 

Went through the 'Ports' and 'Enabling Outbound Azure Connections' sections, made sure everyting was in line with those requirements in particular, and now all fine