cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Scheduled cache refresh for DirectQuery greyed out

Hi, 

 

I have a dataset with a direct connection using DirectQuery and would like to schedule cache refresh so that the dataset doesn't update everytime a user interacts with it. However, I cannot set the refresh frequency, as it is greyed out. 

 

Does anyone know what my issue could be? 

1 ACCEPTED SOLUTION

hi, @Anonymous 

It's pleasant that it works well now. Could you please tell me if you have other problem? If not, could you please mark the helpful replies as Answered?  Smiley Very Happy

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
fijijuan
New Member

I have the opposite problem.  I have a dataset that I cannot turn off the scheduled cache refresh. The check box is grayed out in the on position.  I'm not comfortable creating these real-time reports (that create their own dataset), and then they are auto being refreshed every hour.  Some of these reports don't even get used after a few weeks. I rather the database hit occur only when user opens the report.

That is why I chose direct query.  I did not want to schedule the dataset, and our end users are consuming via the app, so they dont have ability to refresh the dataset in the workspace manually.

v-lili6-msft
Community Support
Community Support

hi, @Anonymous 

You need to add the data source into gateway and enable it as below, then it will work well.

6.JPG7.JPG

 

https://docs.microsoft.com/en-us/power-bi/refresh-data#live-connections-and-directquery-to-on-premises-data-sources

https://docs.microsoft.com/en-us/power-bi/service-gateway-manage

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thank you for your reply. The data gateway was insalled and running but the field was still greyed out. However today I can set the refresh schedule for some reason. Maybe I just had to give it some time. 

hi, @Anonymous 

It's pleasant that it works well now. Could you please tell me if you have other problem? If not, could you please mark the helpful replies as Answered?  Smiley Very Happy

 

Best Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors