cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
llaved
New Member

Scheduled Refresh of Excel file using On-Premise gateway greyed out.

Hello, 

I have recently added an Excel Data Source into the On-Premises Gateway

llaved_0-1618914449597.png


It has been added in from a network path using the full UNC path and it connects successfully with the credentials I provide.
File added into a report in Desktop using the same UNC Path

llaved_1-1618914570388.png


When I go to Schedule the refresh the gateway is greyed out.
This works fine for Database Data Sources, appears to be File/Excel that is the issue.

I have tried using numerous accounts on the Gateway data source permission, all of which connect at the manage gateway section but same result at schedule refresh

llaved_2-1618916073876.png

Any ideas?

1 ACCEPTED SOLUTION
llaved
New Member

Hi There, Thanks for the response.
Yes, I did add in a new data source.

I have an update where it is working but not in any way that I understand.
What I forgot to mention was that the Gateway administrator accounts are different to my normal account, so I have to log in to the PowerBI Service and Manage Gateways through a Private Window (in this case Chrome Incognito).
I created a new excel data source and then created a new report, uploaded the report, scheduled refresh gateway was greyed out.
I then decided to add my normal account as administrator of the gateway.
This time when I go to schedule refresh it is not greyed out but says the data source is not configured correctly and offers me to add the data source to the gateway.
I do this, add in the data source and lo and behold it works.
However I now have 2 data sources of exactly the same path, configured exactly the same. It makes no sense to me why it would only recognise one of the data sources which are identical and only once I had added the account I was trying to schedule the refresh on as an Administrator of the Gateway.
I don't seem to have an option to remove/delete the duplicate Data Source either. My understanding is there should be a delete button but it isn't there

View solution in original post

4 REPLIES 4
v-henryk-mstf
Community Support
Community Support

Hi @llaved ,

 

Whether your question has been resolved, if it has been resolved, please mark the correct response as the correct answer.

If there are still problems, please provide detailed error information and screenshots, I will answer you as soon as possible


Let me know the result immediately and looking forward to your reply.

 

Best Regards,
Henry

 

llaved
New Member

Found the delete with the elpsis after the Data Source name (only after a google search!) Very well hidden! 😄 

llaved
New Member

Hi There, Thanks for the response.
Yes, I did add in a new data source.

I have an update where it is working but not in any way that I understand.
What I forgot to mention was that the Gateway administrator accounts are different to my normal account, so I have to log in to the PowerBI Service and Manage Gateways through a Private Window (in this case Chrome Incognito).
I created a new excel data source and then created a new report, uploaded the report, scheduled refresh gateway was greyed out.
I then decided to add my normal account as administrator of the gateway.
This time when I go to schedule refresh it is not greyed out but says the data source is not configured correctly and offers me to add the data source to the gateway.
I do this, add in the data source and lo and behold it works.
However I now have 2 data sources of exactly the same path, configured exactly the same. It makes no sense to me why it would only recognise one of the data sources which are identical and only once I had added the account I was trying to schedule the refresh on as an Administrator of the Gateway.
I don't seem to have an option to remove/delete the duplicate Data Source either. My understanding is there should be a delete button but it isn't there

View solution in original post

ibarrau
Super User II
Super User II

Hi. The thing is you can not edit the path of the files. You can only edit the credentials. If you have to change the path it's considered a completely different source. So if you have a different path you have to add a new source from scratch. That's the way Power Bi Manage Gateway works. Remember you can have several sources in the gateway configured. You can have two or more excel path configured.

If you want to change the source for an specific dataset anytime, then you have to consider parameters like this video: https://www.youtube.com/watch?v=OnaDJkGOmIE

I hope that helps,


If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Happy to help!

LaDataWeb Blog

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors