cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
spinachbisque
New Member

Scheduled Refresh Succeeds but Data Won't Update

I have built a Power BI report that queries data from a SQL Server database at my organization. I've uploaded the report to Power BI online and set up a scheduled refresh with the help of our IT staff. Everything is showing as "green" and I get confirmation that the data refresh succeeds each time it's set to occur. There is no error message or other notification that the refresh failed. HOWEVER, the actual data in the report does not update to reflect the most current data in our SQL Server database. 

 

When I go into Power BI Desktop and hit the "Refresh" button on the report manually, the data DOES update and show correctly based on the current data in the SQL Server databse. 

 

Is there a way to fix this issue so that the scheduled refresh in Power BI will actually update based on the most current data in our database? 

1 ACCEPTED SOLUTION

@spinachbisque How quickly are you checking the report after the dataset has said it has refreshed? The Dataset, Report and dashboard are seperate objects and are not all immediately refreshed after the dataset. It is in order. If the dataset refreshes, it is likely it will be 10-15 before the report, and then the Dashboard. You can also initiate a refresh in the report after the dataset.

If you know, and or tried the above, then this sounds like a bug or issue that you should raise in a support ticket or the issues page.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

View solution in original post

37 REPLIES 37
Vickar
Frequent Visitor

I faced the same issue, republishing the PBIX to the Service worked for me.

Vickar
Frequent Visitor

Exactly after a month, today, I again encountered the same issue and again had to republish the PBIX to service to get the up-to-date data

alsasloren
Post Patron
Post Patron

I'm facing with same issue.

Datasource is sharepoint.
Schedule Refreshes look like worked but data set didn't updated...
2.5 years passed and still no acceptable solution...

brenda_k
Advocate I
Advocate I

Hello,

Did anyone have a solution to this issue? Because I had the similar issue too - scheduled refresh was complete but data was not updated completely. 

I had to trigger the "refresh now" manually on my dataflow in powerbi service and data was updated..   

 

Not sure why this is happening, it works fine sometimes, but now this problem kept occurring after rescheduled data refresh in the morning.. 

Hi @brenda_k ,  I'll copy in my solution I posted earlier that worked for my team. 

 

Hi everyone, I thought I'd weigh in on a solution I found to a similar issue. Our underlying data sources was primarily a DataFlow, however we also did have a few other alternative sources such as Excel spreadsheets that we accessed. Similarly, we were able to refresh the report manually via the PowerBI Desktop. Our DataFlow would successfully refresh when it was scheduled via the Web Service, however the report itself would not update.

 

The solution we found was that both the DataFlow and the DataSet need to be refreshed in Power BI Web. Refreshing only one of these meant that the underlying data would not be completely updated, therefore preventing the report from being updated. We then made sure to schedule a refresh for both data sources which successfully resolved the issue. An important note is that you should stagger the scheduling as the Web Service can take 5 to 10 minutes to completely refresh the data source (or longer, dependent on how much data you have. For example, we scheduled the DataFlow to refresh at 8:00am and the DataSet to refresh at 8:30am, so that the report will be updated by 9:00am every morning.

 

Also, make sure that your gateways are correctly setup.

Thank You Glorfendal, 
You solved why my Power BI Reports were not getting updated with refreshed data. 
I was missing the fact that the DataFlow needed to be refreshed before the DataSet. i.e. As a paired set. 
Many thanks. 
SteveB

@Glorfendal  thanks for sharing your solution. 

Currently, my dataset and dataflow scheduled data refresh is staggered, so this is not the root cause. 

 

After my dataflow had a completed scheduled data refresh,  I realized the data was only updated to a certain date rather than to the latest available data when I connected the dataflow in power bi desktop. 

 

However, if I triggered the "refresh now" button on powerbi service, the dataflow is updated to the latest date.

Glorfendal
Regular Visitor

Hi everyone, I thought I'd weigh in on a solution I found to a similar issue.

 

Our underlying data sources was primarily a DataFlow, however we also did have a few other alternative sources such as Excel spreadsheets that we accessed. Similarly, we were able to refresh the report manually via the PowerBI Desktop. Our DataFlow would successfully refresh when it was scheduled via the Web Service, however the report itself would not update.

 

The solution we found was that both the DataFlow and the DataSet need to be refreshed. Refreshing only one of these meant that the underlying data would not be completely updated, therefore preventing the report from being updated. We then made sure to schedule a refresh for both data sources which successfully resolved the issue. An important note is that you should stagger the scheduling as the Web Service can take 5 to 10 minutes to completely refresh the data source (or longer, dependent on how much data you have. For example, we scheduled the DataFlow to refresh at 8:00am and the DataSet to refresh at 8:30am, so that the report will be updated by 9:00am every morning.

 

Also, make sure that your gateways are correctly setup.

How exactly does one schedule a refresh for data flow?

I know how to configure scheduling the data set refrsh but where is the data flow refresh?

 

I'm also still having issues, planned refresh seems to be working but I don't see new data until I first manually refresh the dataset and after that refresh the data on the report. Very annoying.

Anonymous
Not applicable

Did you find a solution to this problem? I'm having the same issue and can't figure out why it is happening when I refresh manually it works fine.

 

Thanks,

Askal

Since having to set up the gateway on a new machine, it's been working OK for a month now.

bentz
Frequent Visitor

Hi everyone,

i have the same issue. Scheduled refresh takes place successfully at 7 am. At 9 am the report still shows the values for the previous day after manual report refresh.

After manual refresh of the data set and the report the report shows the correct data. 

 

I use a SQL server backend and a data gateway. 

 

Is there anything to look out for in the data gateway logs?

 

Thanks.

bentz
Frequent Visitor

created a new topic as solution provided in this thread doesn't work. 

 

https://community.powerbi.com/t5/Service/Scheduled-Refresh-Succeeds-but-Data-Won-t-Update-manual-ref...

dgcffy
New Member

I am having exactly this issue with a share point list rather than a mysql db.

I'm curious as to why there's a 'Solved, Go to solution' on this as there's no solution that I can see in this thread.

There are also multiple threads on this exact issue (as far abck as 2016) with no solutions..

There's a reply in here saying one has to close browser tabs, re-open and then manually click refresh.. This is not a solution either, what's the point of scheduling the refresh if you have to manually click a button!!!!

If anyone actually has a reliable solution for this please update the thread, that would be greatly appreciated.

hi try to del and reupload the pbix file to workspace (get data), it worked for me

Cheers for the response @mhsk ,

I have tested that many times, even making fresh BI reports from scratch to rule out if there's any conflict with the original.

Same issue occurs.

I'm using chrome, and a colleague is using firefox, same issue on both browsers. Data source is a share point list.

In the browser I check the report, confirm successful scheduled refreshes took place overnight.

However while the sched refreshes were successful, the data has not been updated in the report.

Refreshing the browser window or manually refreshing the report in the dashboard makes no difference..

So after this, I check the same report in the desktop application and manually refresh it, this runs and updates the report as expected with the data from the SP list.

I go back to the dashboard again (in chrome) and click refresh, in the report and not the browser.., and it updates the data 😕 

I didn't publish the report at any point during this test.

 

It's my understanding that the scheduled refresh should run the same refresh as the desktop application refresh button does, thereby eliminating the need to manually refresh the report from the dashboard at any point.

Am I missing something really simple here?

Any feedback is very welcome.

Morning,

 

I've been pursuing this with the MS support team since it first became an issue for me in April and after numerous email exchanges and screensharing sessions, they don't appear to be any closer to providing a solution.

 

They believe that the problem is related to the data connectivity mode and specifically an issue with datasets suppossedly configured as DirectQuery remaining as an Import model behind the scenes.

 

I'd like to be able to provide more input but I'm becoming increasingly frustrated with the entire affair and the most recent telephone calls with the MS off-shore team have been incredibly discouraging.

 

I'll update this stream if there is further progress.

Thanks for the update on that @ims20180411kjb , really appreciate it.

I can fully understand your frustration, and I guess I can empathize to some extent with the MS devs, it might not be a simple fix. An official update from them however would be something at least, to let users know that their frustrations are not going unheard..

I look forward to your (hopefully positive) future updates, will stay tuned.

Thanks again 🙂

aj_pdx
Regular Visitor

In my case, the server runnning the gateway stuff crashed.  I had to re-set iup the gateway stuff on a different box and it's been working as it should since then.  I don't trust it won't break again, but so far so good...

aj_pdx
Regular Visitor

+1, same here.  Hoping someone has something on this some day soon.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Get Ready for Power BI Dev Camp

Power BI Dev Camp - June 24th

Mark your calendars and join us for our next Power BI Dev Camp!