cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
frenchphil
Frequent Visitor

Schedule refresh of a dataflow from a datalake failed

Hi,

I try to schedule an automatic refresh of my dataflow which is conected to a datalake Storage Gen 2. When I refresh it "on demand", it works properly but the automatic refresh fail with the following error:

"Data source credentials are missing or invalid. Please update the credentials for AzureDataLakeStorage in dataflows settings page and try again"

 

How the credential used for the automatic is stored ? How can we checked it's properly configured? 

 

Each time I'm going to the parameters of the dataflow, I got this message in identification information for the datasource:

frenchphil_0-1641922066917.png

I update identification information by conecting my account but it's like if my account's parameters were not stored ...

 

Any idea ?

 

Thanks

9 REPLIES 9
collinq
Super User
Super User

Hi @frenchphil ,

 

You are correct that you don't need a gateway but you will need to set the credentials in the Service in the dataset.  This blog has a great example at this point "

Azure Data Lake Storage Gen 2 in Power BI Service"

at this link:

Power BI with Azure Data Lake Storage Gen2 – Power BI Desktop & Service | Data Awareness Programme (...




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Hi @collinq

Thanks for the blog, it's well explained and usefull. I hadn't registered the credential at the dataset level. I thought it was my mistake ...

I tried again a scheduled refresh yesterday and it worked.

 

But this morning, the scheduled refresh failed again (with same error) and when I come back in the parameters of my dataflow, the credentials are not set ...

 

frenchphil_0-1641973684518.png

 

In the dataset, it's correctly registered:

frenchphil_1-1641973901954.png

Any idea?

 

 

Hey @frenchphil ,

 

If you are an admin and/or the owner of that report, when you changed the settings it should have held.  I would try it again (add your credentials and refresh it) and then check again tomorrow.  If it goes away again, I would contact Microsoft support because it should stay in place. 




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Hi @collinq 

I am the owner of the dataflow and admin of my organization.

I've done it several times (see above) and it never stays in place more than one hour (approximately). For information, I use the OAuth2 authentification method.

 

frenchphil_1-1642019409027.png

 

 

Hey @frenchphil ,

 

I think you may have to open a ticket with Microsoft.  Seems like some sort of cacheing maybe?  But, settings (almost by definition, need to be permanent or we would all spend our whole day resetting everything 🙂  )




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Allright, I can open a ticket. Never done it before. What is the best way to do it ?

Hi, @frenchphil 


Sorry for that, We cannot reproduce the issue here and also not found an effective solution. We suggest you to open a ticket here for help if you are a pro user: https://powerbi.microsoft.com/en-us/support/

vzhangti_0-1642127051739.gif

 

Best Regards,

Community Support Team _Charlotte

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

frenchphil
Frequent Visitor

Thank you @collinq for your answer ...

 

In my case, I don't have and don't need any gateway because the Datalake is stored in Azure Cloud. It should be possible to schedule a refresh without a gateaway, no?

 

I have read the articles but I don't have the hand on Datalake administration .. I can make the demand if it's necessary but I don't understand why it works on demand on why it doesn't when it's scheduled ... 

 

collinq
Super User
Super User

Hi @frenchphil ,

 

If you are able to run the report yourself and the gateway is not, then the issue is most likely not the userid but the ability of the user to navigate from the gateway to the data lake.

(You may also want to make sure your gateway is updated.)

 

Here are a couple links to help you determine the permissions:

Configuring dataflow storage to use Azure Data Lake Gen 2 - Power BI | Microsoft Docs

Solved: Re: Can't find "Power Query Online" in Azure Activ... - Microsoft Power BI Community

 




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Helpful resources

Announcements
Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

charticulator_carousel_with_text (1).png

Charticulator Design Challenge

Put your data visualization and design skills to the test! This exciting challenge is happening now through May 31st!

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Power BI Dev Camp Session 22 768x460.jpg

Check it out!

Mark your calendars and join us on Thursday, May 26 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors
Top Kudoed Authors