cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Schedule Refresh - PowerBI service Dataset not being updated

Hi All,

I came across similar issue threads but did not find a solution. The situation is -

 

Data source - Snowflake DB 

Connectivity - Import mode 

PowerBI - Premium


On PowerBI desktop when I do the manual refresh the data is being fetched with no issue.
I publish the same report to PowerBi service (Premium) and schedule the refresh (it says scheduled cache refresh) to happen every 1 hour. 

The refreshes are getting through with no issue but the data is still old - same as the state when i published from Desktop. Even when I do an "On demand refresh" on the dataset, the data is not being updated. 

 

Again to get the updated data, I am refreshing in Desktop and then publishing it. This is point less. I must be missing something here.

Also one thing I noticed is - it is not "Scheduled Refresh" that I see here for this particular dataset. It says "Scheduled Cache Refresh" this doesnt even have the custom timings that I can choose like I like for other datasets which are mostly Direct Query.

 

Thanks in advance!

 

Capture.PNGCapture1.PNG

Regards,

Chandana Basani

 

@Greg_Deckler 

1 ACCEPTED SOLUTION

Hi there

Based on your images you are connecting directly to the Snowflake DB

Under the section "Scheduled Cache Refreshing" it says that it has a direct query to the underlying database. This shows that it is not importing any data. And that is why you are not getting those options as you would when importing data.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

View solution in original post

7 REPLIES 7
GilbertQ
Super User
Super User

Hi there

The scheduled cache refresh only applies to the Dashboard items.

If you are using a Power BI report you either have to refresh the page or use the new Change Detection feature which is available in Power BI Desktop and Power BI premium.

https://powerbi.microsoft.com/en-us/blog/power-bi-desktop-june-2020-feature-summary/#_APR




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Hi @GilbertQ 

Thanks for your response. This is a PowerBI report that I published as usual. So, is there something specific to the Import mode or snowflake as data source which is preventing the "Scheduled Refresh" to show ? 

 

When I publish a report with SQL server DB table as a datasource on Import mode, "Schedule Refresh" shows up. This is our first report pointing to Snowflake as the datasource. 

 

Regards,

Chandana Basani

Hi there

That is because you are using a direct query to snowflake.

Each time you interact with the report it gets the latest information. No data is imported/stored in your PBIX.




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Hello @GilbertQ 

 

Thanks for the response. For all my tables in the report I chose Import. None of them are direct query. 

 

So for my problem here, where the data in the report (import mode)  is not being updated whatever I do in PowerBI service - refresh now (on demand), schedule cache refresh, refresh the browser, refresh the report on refresh icon - what is the option, please suggest. 

 

I will try page refresh and detect any change new feature but I am not sure yet that would solve. I will update here in the chain. 

 

Just to clarify, It is not direct query but import connectivity mode to Snowflake DB. 

 

Regards,

CB

 

Hi there

Based on your images you are connecting directly to the Snowflake DB

Under the section "Scheduled Cache Refreshing" it says that it has a direct query to the underlying database. This shows that it is not importing any data. And that is why you are not getting those options as you would when importing data.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Hi @GilbertQ 

 

Yeah. Thats what I was confused about. I thought I was using all the tables in import mode and the direct query options show up. I double checked. My bad. Out of a number of tables one table was missed to be updated to import. It was set to Direct Query. Thank you so much for your response. It helped.  

 

The Data is updated with scheduled refresh as usual.

 

Regards,

Chandana Basani

Happy to help!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
November 2022 Update

Check it Out!

Click here to read more about the November 2022 updates!

Microsoft 365 Conference â__ December 6-8, 2022

Microsoft 365 Conference - 06-08 December

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors