cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Barakn
Frequent Visitor

Role Permission tabular not working in Power bi site

when i set a user in role (read permission) on tabular model .  

In power bi desktop it work fine , the data is filtered like i want.
but when i publish it or create it from power bi site 
the filter not working in reports or dashboard.

I installed the SSAS connector correctly and i saw the EffectiveUserName in my Profiler when sent from the power bi site 

not working for me 
any ideas ?


1 ACCEPTED SOLUTION
Barakn
Frequent Visitor

it's ok 
i found the  problem and filters in power bi site  work fine !

i put the user  in Domain Admin in AD  by mistake.

and by doing it  the role not filter the data from power bi site not working  (i don't  know what is the connection yet) 
but is work when i get it out  and leave it  only in Domain Users in AD
littel strange i know but  it  work 

1. The  user for the  SSAS Connector  is  different user 
2. the user i mean is not admin on tabular  only  in role permission 



View solution in original post

3 REPLIES 3
MaheshDadhich
Helper I
Helper I

For me as well data is not appearing in Power BI desktop as per role mentioned in SSAS Tabular Model.  SSAS Tabular Model is my source in Power BI desktop.  

It is hapening strange ...data is appearing only for one table as per role in tabular model but not for other tables.

 

I have defined row level security as below in model

 

=Fact_Sales_Order_Detail_Order_Status_Suite[Separation_Company_Identifier]="1" || Fact_Sales_Order_Detail_Order_Status_Suite[Separation_Company_Identifier]="2"

 

But I am not able to see any data as per this permission where as can see data in model browser in SSMS

 

Can you help and suggest anything 

meysun
Resolver IV
Resolver IV

Hope you are using the 'Explore live' option in Power BI Desktop when connecting to SSAS Tabular and not 'select items to import'

How did you set up the RLS in tabular?

Barakn
Frequent Visitor

it's ok 
i found the  problem and filters in power bi site  work fine !

i put the user  in Domain Admin in AD  by mistake.

and by doing it  the role not filter the data from power bi site not working  (i don't  know what is the connection yet) 
but is work when i get it out  and leave it  only in Domain Users in AD
littel strange i know but  it  work 

1. The  user for the  SSAS Connector  is  different user 
2. the user i mean is not admin on tabular  only  in role permission 



Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

Top Solution Authors