cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
atrguy Frequent Visitor
Frequent Visitor

Reports suddenly won't refresh...claimining I need a data gateway...but used to work fine

I have two reports that I published a week ago, and they have been refreshing fine, multiple times a day on schedule up until two days ago.  The scheduled refresh is now disabled, and the error is claiming that I need a "Gateway" to get it to refresh again.  I've never had a gateway running before, and I'm not really sure what's going on here.

 

The only data sources I have in my report are a few websources from Wikipedia...I'm not sure why these would suddenly need a gateway?  I have other reports that have similar web sources in them and they all refresh fine. 

 

I have deleted the reports from PowerBI service and reuploaded them, renamed them, deleted them, and added them again.  Still same behaviour.  This is only on my two latest reports.  I have a dozen other reports that are all refreshing fine...

 

Any thoughts? 

 

PS:  I have opened a support ticket and the response I got was to install a personal gateway...which I think kind of misses the point here...

1 ACCEPTED SOLUTION

Accepted Solutions
atrguy Frequent Visitor
Frequent Visitor

Re: Reports suddenly won't refresh...claimining I need a data gateway...but used to work fine

While this data source literally worked a week ago, for whatever reason it decided to stop refreshing and require a gateway: 

 

Web.Page(Web.Contents("https://en.wikipedia.org/wiki/List_of_airline_codes"))

 

Seems fairly random and arbitrary, but now I know.  Removed those data sources and it's working fine without a gateway again.  

 

This data source can obviously work without a gateway, as it worked fine for me for a week at least.  I wonder why they choose to block it and require a gateway...

 

Seems the "Web.Page" web.contents is the culprit.  If i do a "Source = Json.Document(Web.Contents..." this still works fine without a gateway.  

 

 

 

3 REPLIES 3
atrguy Frequent Visitor
Frequent Visitor

Re: Reports suddenly won't refresh...claimining I need a data gateway...but used to work fine

Here is a screenshot of the error I have been getting...

 

error.png

Community Support Team
Community Support Team

Re: Reports suddenly won't refresh...claimining I need a data gateway...but used to work fine

Hi @atrguy

 

It seems you may try to install the on-premise data gateway.For further,please refer to below post.

https://community.powerbi.com/t5/Service/Trouble-avoiding-gateway-installations-for-scheduled-refres...

 

Regards,
Cherie

Community Support Team _ Cherie Chen
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
atrguy Frequent Visitor
Frequent Visitor

Re: Reports suddenly won't refresh...claimining I need a data gateway...but used to work fine

While this data source literally worked a week ago, for whatever reason it decided to stop refreshing and require a gateway: 

 

Web.Page(Web.Contents("https://en.wikipedia.org/wiki/List_of_airline_codes"))

 

Seems fairly random and arbitrary, but now I know.  Removed those data sources and it's working fine without a gateway again.  

 

This data source can obviously work without a gateway, as it worked fine for me for a week at least.  I wonder why they choose to block it and require a gateway...

 

Seems the "Web.Page" web.contents is the culprit.  If i do a "Source = Json.Document(Web.Contents..." this still works fine without a gateway.