cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper II
Helper II

Report using dataflow as data source not getting updated data

I've taken the following steps:

  • Created a dataflow using the salesforce connector
  • Set up scheduled refresh
  • Created a report in Desktop and set the data source as this dataflow
  • Published the report to a workspace resident in a premium capacity

My expectation after doing this was that the report would automatically (or perhaps with a "refresh" click in the Service) get updated data from the dataflow.  While the dataflow is completing its scheduled refreshes successfully, the only way I seem to be able to get that updated data to show up in the report is to do a manual refresh from Desktop and republish the report.  My impression was that dataflows were meant to obviate that workflow.  Have I missed something?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper II
Helper II

Re: Report using dataflow as data source not getting updated data

Ok, I'm a moron.  I did not realize that in addition to setting up a refresh schedule for the dataflow, that I also had to set up a refresh schedule for the report's dataset.  I've set that up now, and I'll see how it goes.

View solution in original post

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Report using dataflow as data source not getting updated data

@andrewbrick,

 

Which kind of error does power bi throw? Can you connect to Salesforce suucessfully in dataflow, if you can't connect to salesforce successfully,  use a production Salesforce account or a developer account for testing instead of trial account. In addtion, if the report doesn't refresh in power bi service, please click dataset-> schedule refresh to check if there's something wrong with credentials or others.

 

Community Support Team _ Jimmy Tao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Highlighted
Helper II
Helper II

Re: Report using dataflow as data source not getting updated data

Power BI is not throwing an error. As I said in my original post, the dataflow creation process (to a production Salesforce instance) *and the scheduled refreshes* all succeeded without error. The dataflow continues to do its twice-daily scheduled refresh without error, and I've confirmed that the dataflow is, in fact, grabbing updated data from Salesforce. The problem is that the report that uses that dataflow as a data source is not reflecting the updated/new data that the dataflow is getting. The only data the report shows is what was present in the dataflow at the time I created the report in Desktop and published it to the service. Additionally, as I said in my original post, if I manually refresh the report in Desktop, it pulls down all the latest data in the dataflow. What appears to be missing is a link between the dataflow *in the Service* and the report *in the Service*.
Highlighted
Helper II
Helper II

Re: Report using dataflow as data source not getting updated data

Here are some snaps:

 

The dataflow, showing last refresh this morning at 6am:

 

refresh.PNG

 

The report in the Service.  Note the latest data available:

 

service.PNG

 

 

The report in Desktop, which I just manually refreshed:

 

desktop.PNG

 

So, when in Desktop, a refresh pulls the very latest data from the dataflow.  But the report in the Service isn't getting any of that new data.  I thought that was one of the big selling points of dataflows -- that I wouldn't have to manually refresh and republish the report every day.

Highlighted
Helper II
Helper II

Re: Report using dataflow as data source not getting updated data

Ok, I'm a moron.  I did not realize that in addition to setting up a refresh schedule for the dataflow, that I also had to set up a refresh schedule for the report's dataset.  I've set that up now, and I'll see how it goes.

View solution in original post

Highlighted
Skilled Sharer
Skilled Sharer

Re: Report using dataflow as data source not getting updated data

Came across this issue myself when first using dataflows. There is an idea that you can vote for, it describes a single schedule refresh for both dataflows and datasets: https://ideas.powerbi.com/forums/265200-power-bi-ideas/suggestions/36119359-one-single-schedule-task...

Highlighted
Frequent Visitor

Re: Report using dataflow as data source not getting updated data

I'm having the same issue myself and it's driving me crazy.

 

Here's my setup:

  1. I have created a Power BI report using the desktop app, which I published for others to access.
  2. The report only uses data found in published dataflow's. 
  3. One of those dataflows has an Excel URL as its source.
  4. The Excel document is modifed as users fill out a form we created.
  5. The data is this form is pulled into Power BI and tied into other objects.
    1. Example: Hostname "EC13AQ1" ties into any "COMMENT" in the excel document with a matching "HOSTNAME."

Updates found in the dataflow aren't making there way to the publish Power BI report.

 

 

My testing scenario.

  1. A user is accessing the published power BI report. 
  2. They see a hostname they need to comment on.
  3. They pull up the Form, enter the hostname in the appropriate box, enter some comments, hit submit.
  4. The excel file gets updated.
  5. Even though I'm only using dataflows for data sources, when I published the report a dataset was created with the same name. A trigger was built using Flow that tells Power BI to refresh the dataset for this report every time the form is submitted. I see this working. When a user submits the form, if I watch the Power BI datasets list, I see the refresh icon light up.
  6. But, the end users never see the updated data in the published Power BI report. I have all the datasets and the dataflow all configured to refresh every 3 hours but the data never makes it to the published report. If I inspect the dataflow tied to the Excel document, I see the new entry there, but it's not being accessed by the published report.
  7. I have to manually publish the report again in order for anyone to see the new comments. This is the problem. I cant continuously republish this document all day long in order to get peoples comments to show up to everyone else.

I'm at a loss.

 

 

 

 

Helpful resources

Announcements
Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Galleries

Galleries

Looking for inspiration on how to present your data? Need instructional videos? Check out our Galleries!

Community Summit North America

Community Summit North America

Innovate, Collaborate, Grow. The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors