cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SBPFA
Helper I
Helper I

Report does not display refreshed data

Hi,

We have a SSAS that retrieves data from a MySQL using a scheduled job, which invokes the Refresh command with the "full" refresh type (see https://docs.microsoft.com/en-us/analysis-services/tmsl/refresh-command-tmsl?view=asallproducts-allv...

 

This job started failing due to "out of memory" and "timeout reading communication packets from mySQL" errors.

So I changed the refresh type to "automatic" and worked fine, since adding more memory is currently not possible. The job runs fine, and after manually updating the dataset in powerbi.com, new dates appear in the reports' filters, as if new data is available, but it is not shown:

PowerBInodata_LI.jpgIf I change the filter to display data from march, it works (all new data is from april and may).

I tried executing the refresh command using types "calculated" and "add", but the model has calculation partitions and didn't worked. I don't know exactly what "clearValues" does, so I didn´t try it.

 

Also on-premises data gateway is updated to the latest version.

 

Any suggestions?

thanks.

 

1 REPLY 1
GilbertQ
Super User II
Super User II

Hi @SBPFA 

 

What happens if you have to change the partitions to be monthly instead of the past N years.


What I mean is change the partitions from the last 2 years to the last 24 Months, this will run a query to process each partition monthly which can return the data quicker.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!