cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sjors Frequent Visitor
Frequent Visitor

Re: Report couldn't access data source in Direct Query mode

I've created the same test on my own pc with a local sql server and published it. And this works fine.

Your suggestions about the credentials are probably right. Now its up to me to figure this one out.

At first I published from Desktop using the import sql feature, later I used (with a new file) the direct query option. Both using the same gateway. Can this somehow be the root of the problem?

 

Thanks for the help. I´ll keep this thread open for a little longer until I got it working on premise

 

zoloturu
Advisor

Re: Report couldn't access data source in Direct Query mode

@Sjors,

 

Did you map user from PBI service to Windows account user here?

 

mapping.pngmapping

Sjors Frequent Visitor
Frequent Visitor

Re: Report couldn't access data source in Direct Query mode

I don't have a button for this. I can only add or remove users

Highlighted
zoloturu
Advisor

Re: Report couldn't access data source in Direct Query mode

@Sjors,

 

If you configured Gateway but yourself then you should have user under USERS tab (see screenshot). Provide your screenshot.

Sjors Frequent Visitor
Frequent Visitor

Re: Report couldn't access data source in Direct Query mode

This was not the problem. I deleted the data source under the gateway and added it again. Now it works 

 

Sjors Frequent Visitor
Frequent Visitor

Re: Report couldn't access data source in Direct Query mode

No it had to do with the credentials in the gateway. Problem solved already. Thanks for the reply