Reply
Occasional Visitor
Posts: 1
Registered: ‎09-17-2018

Re: Report colors changing when published

I'm getting following message when i clicked on the link.

 

You do not have sufficient privileges for this resource or its parent to perform this action.

Frequent Visitor
Posts: 9
Registered: ‎04-30-2018

Re: Report colors changing when published

Hi Madinenv,

Questions:
1. Are you working on a Power BI trial (free) license?

2. Are you working on the online version or desktop?

 

Considerations:
1 - The Power BI free trial has limited options.

2 - The online version user control seem to be more limited than the desktop version.

Hope this helps.

Frequent Visitor
Posts: 9
Registered: ‎04-30-2018

Re: Report colors changing when published

Not sure if this was an update - but colors can now be selected for specific levels in a chart and published version remains the same.
For example:
Visualizations/Paintbrush(editing tab):
Categor 1 Colors (Select desired colors)
Colors will change in visual.
Colors will remain the selected color when published Smiley Happy

[Using ZoomCharts]

Frequent Visitor
Posts: 3
Registered: ‎09-28-2018

Re: Report colors changing when published

I do see similar issue when I publish the report. I have pie chart and clustered bar chart with multiple values, I manually edited the color in clustered bar chart to sync with pie chart. Once I deploy this report these changes are gone. This there any work around for this issue?

Frequent Visitor
Posts: 9
Registered: ‎04-30-2018

Re: Report colors changing when published

Hi Harin,

I created a bar chart and pie chart from the same dataset and selected the colors.
When published it looked fine.


My thoughts:
1. If you could share more details I might be able to replicate your issue and see if there is a workaround.

2. Is the data for both charts coming from the same dataset? Different data sets? Do the datasets have a relationship?

Highlighted
Frequent Visitor
Posts: 3
Registered: ‎03-21-2018

Re: Report colors changing when published

I see this issue in my reports as well and I just use the defualt colour scheme. It is very frustrating when a manager comes to you asking why the colours in your reports are not consistent. I build them consistently in Power BI Desktop, but when I open them in the service they are different and there doesn't seem to be any rhyme or reason to which ones change and which ones stay the same. I would love to know if this issue is going to be fixed by MS anytime soon.