cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User II
Super User II

Report Theming Lost when Deployed to App?

Hi there - I'm seeing a bit of a weird isue with theming in my environment and wondered if this was known about? I've seen a similar issue on here but as this relates to publish to web, I'm not sure if it's the same or not.

 

In order to streamline some of the more tedious parts of report authoring, I've extended our theme to use a number of the new GA features.

 

This works perfectly in Desktop, and within the app workspace in the service, but when I publish, the theming is not applied. This only seems to affect an existing report (publish from desktop and overwrite, then publish the app).

 

Here's the top of the report using Desktop/app workspace:

 

 

And, here it is when I publish the app:

 

 

At this point it's pretty obvious that I'm using some cards in the matrix to be a bit more dynamic but these all just revert back to the 'non-theme' defaults and it's quite obvious that I'm being a bit hacky 😉 Although, none of the other values are being applied, including the newer options for page background and outspace.

 

It appears to be possible to work around the problem by deleting the report from the workspace, then re-publishing, but this may not be ideal if the report contains a dataset used by the published app (fortunately, my report uses a live connection to another dataset in the workspace).

 

Here's the theme code:

 

{
    "name": "MLC",
    "foreground": "#6D6E71",
    "dataColors": [
        "#1F3E7C",
        "#A18457",
        "#1B75BC",
        "#6D6E71",
        "#F19F53",
        "#F16278",
        "#9279B7",
        "#A4CF5F",
        "#44C1C0"
    ],
    "visualStyles": {
        "*": {
            "*": {
                "*": [
                    {
                        "fontFamily": "Segoe UI",
                        "fontSize": 8
                    }
                ],
                "general": [
                    {
                        "responsive": true
                    }
                ],
                "legend": [
                    {
                        "show": true,
                        "position": "TopCenter",
                        "labelColor": { 
                            "solid": { 
                                "color": "#6D6E71" 
                            } 
                        }
                    }
                ],
                "background": [
                    {
                        "show": true,
                        "color": {
                            "solid": {
                                "color": "#ffffff"
                            }
                        },
                        "transparency": 0
                    }
                ],
                "categoryAxis": [
                    {
                        "fontFamily": "Segoe UI",
                        "fontSize": 11
                    }
                ],
                "valueAxis": [
                    {
                        "fontFamily": "Segoe UI",
                        "fontSize": 11
                    }
                ],
                "title": [
                    {
                        "fontColor": { 
                            "solid": { 
                                "color": "#1F3E7C" 
                            } 
                        },
                        "fontFamily": "Segoe UI",
                        "fontSize": 10
                    }
                ]
            }
        },
        "page": {
            "*": {
                "background": [
                    {
                        "color": {
                            "solid": {
                                "color": "#e6e6e6"
                            }
                        },
                        "transparency": 0
                    }
                ],
                "outspace": [
                    {
                        "color": {
                            "solid": {
                                "color": "#e6e6e6"
                            }
                        },
                        "transparency": 95
                    }
                ]
            }
        },
        "slicer": {
            "*": {
                "background": [
                    {
                        "show": false,
                        "color": {
                            "solid": {
                                "color": "#ffffff"
                            }
                        },
                        "transparency": 100
                    }
                ],
                "items": [
                    {
                        "fontColor": { 
                            "solid": { 
                                "color": "#6D6E71" 
                            } 
                        },
                        "textSize": 8,
                        "background": {
                            "solid": { 
                                "color": "#FFFFFF" 
                            }                             
                        }
                    }
                ]               
            }
        }
    }
}

 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




5 REPLIES 5
Community Support
Community Support

HI @dm-p,

 

I can't reproduce your issue, I test to enable your theme file on my report and publish to both two version of workspace apps and both of them works.

 

Can you please share more detail information about your issue or share a sample pbix file to test?

How to Get Your Question Answered Quickly

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Hi @v-shex-msft and thanks for coming back.

 

Unfortunately I'm not in the position to share a workbook at present as my current workbooks contain sensitive data. I'll have to see if I can put something together, but I've been able to reproduce within my tenant for a separate report in a different app workspace. My conditions/reproduction steps are as follows:

 

  • Workspace is v1 (Office 365 group).
  • The report you are wishing to publish needs to be present in the workspace already.
  • The report does not contain the theme.
  • Apply theme to an existing report in Power BI Desktop (I'm on 2.63.3272.40461 currently)
  • Publish report to workspace (overwriting current report).
  • View report in workspace, confirming it's the same as desktop.
  • Update the app using the publication process
  • Navigate to the published app - issue occurs

 

The only differences in conditions between this and my first post was that one report was using a live connection in the same workspace, and the one I've just tried was a report containing a dataset. I get the affected app theming on my phone, and the UWP app as well.

 

What's interesting is that if I do the following in either my web browser (tested in Chrome, Edge and IE), UWP app or phone, I temporarily get the correct theming in the app report:

 

  1. Navigate back to the workspace
  2. Open the report (this is as expected)
  3. Navigate back to the published app and open the affected report

This is not a permanent solution and I'll get the incorrect theming back after I manually refresh the page in any of these locations. Unfortunately it's a workaround I can't offer my stakeholders, as we don't permit workspace access and use apps as our front end for the Business.

 

Hopefully this clarifies things a bit more for you?

 

Thanks very much,

 

Daniel





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Hi @dm-p,

 

It sounds like new report not fully replaced the old one, I'd like to suggest you to unpublish original one and re-publish the new version instead direct update on published app.

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Thanks @v-shex-msft - so, the workaround I've been using is the "right" way to handle this?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Hi @dm-p,

 

You can try to unpublished these resource and remove them on service side.

 

After these, you can modify your report and publish the new version to same place, then use these new contents to create a app and share to confirm if that issue still appears.

 

If same issue appears on new resource, I think this issue should more related to power bi service. Please open a support ticket for better support.  If issue disappeared, that issue may related report cache data which stored on service side.

 

Regards,

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

Helpful resources

Announcements
November Update

Check it Out!

Click here to read more about the November 2020 Updates!

Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

secondImage

Power Platform October Community Highlights

Check out the top community contributors across all of the communities

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors
Top Kudoed Authors