cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
konstantinos Senior Member
Senior Member

Regional Settings strange behaviour in Desctop, PowerBI Service, iPad app

 

Is there is a bug in regional settings display (at least for us in Europe ) or at least I cannot get the regional setting to work properly in  all services. I am in Europe so decimal seperator must be comma ( ; ) and thousand seperator a dot ( . )..

 

I have tried many different regional settings...The currents are:

Windows 10  & PBI Desktop version ( 2.26.4128.403 )

Region : Netherlands 

Regional format : Netherlands

Language ( English USA )

 

This is the situation

 

PowerBI desktop query Data load locale is Netherlands..( in formula editor i can use semicolon ) The query editor shows decimal numbers with comma ( correct ) 

 

Query.png

 

 

 

The Data View shows the decimal numbers with dot ( wrong )

 

Data.png

 

 

Now it get interesting..I create 2 measures and place them in report as cards..One is formatted as currency and the second as number with thousand seperator. The result ? ...Currency uses comma and number uses dot..

 

 

 

PBID.png

 

 

If the above is not interesting enough  when I upload the data to PowerBI service..... the comma and dot in the same measures in tiles ( and in report ) are opposite..dot for currency and comma for number..

 

 

Browser.png

I left the most cool picture for the end..In a column chart the numbers are with dot..but hovering with mouse over the column card detail is using comma...haha

 

chart.png

 

 

 

 

If anyone has any ideas please be my guest..I think it broke with the last couple updates..Do anyone know from what source every service reads the regional formats..i.e. PBI desktop uses windows advanced regional setting or regional format...

 

Hope I have made some stupid mistake and can solve this soon as last time the bug with powerpivot editor comma & dot problem it took 5 months for a fix..

Konstantinos Ioannou
1 REPLY 1
konstantinos Senior Member
Senior Member

Re: Regional Settings strange behaviour in Desctop, PowerBI Service, iPad app

I forgot that in the PowerBI app the measures both use commas..!!!!

Konstantinos Ioannou

Helpful resources

Announcements
Can You Solve These Challenge

Challenge: Can You Solve These?

Find out how to participate in the first Power BI 'Can You Solve These?' challenge.

Community News & Announcements

Community News & Announcements

Get your latest community news and announcements.

Virtual Launch Event

Microsoft Business Applications October Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

Community Kudopalooza

Win Power BI Swag with Community Kudopalooza!

Each week, complete activities and be qualified in the drawing for cool Power BI Swag.

Users Online
Currently online: 6 members 4,177 guests
Please welcome our newest community members: