cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

Refresh fails, took longer than 120 mins

I have a pbix that has a 4 sharepoint xlsx files as its datasource. When refreshing from PBI Desktop, it finishes in under 2 mins.

 

When I publish it to service and set up the credentials and refresh, it fails with the error:

 

The refresh operation failed because it took more than 120 minutes to complete. Consider reducing the size of your dataset or breaking it up into smaller datasets.

 

it is also in a Premium workspace, Any thoughts or ideas would be much appreciated!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: Refresh fails, took longer than 120 mins

Thanks for the help everyone. Looks like there was a table which was not included in the refresh, but enabled in the load which was causing the problem.

View solution in original post

5 REPLIES 5
Highlighted
Community Champion
Community Champion

Re: Refresh fails, took longer than 120 mins

Does it use a data gateway? Where is the data gateway located in relation to the data sources?  If you had the ability to run the refresh Power BI Desktop on the same machine as the data gateway, would it take 120 minutes also?

Highlighted
Helper I
Helper I

Re: Refresh fails, took longer than 120 mins

No gateway involved. Credentials are provided for Service to connect to the xls files in sharepoint directly. 

 

Running refresh in pbi desktop takes less than 3 mins to complete.

 

Highlighted
Community Support
Community Support

Re: Refresh fails, took longer than 120 mins

Hi @nwrong,

 

It is hard to reproduce your issue from your description. Can you please share the sample pbix file for further test?

 

Regards.

Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Refresh fails, took longer than 120 mins

Thanks for the help everyone. Looks like there was a table which was not included in the refresh, but enabled in the load which was causing the problem.

View solution in original post

Highlighted
New Member

Re: Refresh fails, took longer than 120 mins

Hi ,

 

I am facing the same problem. Can you guide what have you done to resolve this issue. 

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Community Summit Australia – Join Online!

Community Summit Australia – Join Online!

Be a part of the leading Microsoft Business Applications digital event, curated for the APAC community.

Top Solution Authors
Top Kudoed Authors