cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Refresh fail due to merged queries

Hello!

When I am merging two queries , one from PostgreSQL and another from Sharepoint, I get an error "We cannot convert the value "[Binary]" to type Binary, when I am trying to refresh data set in cloud.  I have tried to use many things from community like DAX as merging queries work around, also looked at gateway logs, privacy levels and etc. but nothing helped. Registered case to support, they tried many things as work around, checked privacy settings and etc. but again the problem still occurs.  Any ideas? 

3 REPLIES 3
Microsoft
Microsoft

Hi @mantas011,

 

Were you able to refresh the dataset on Power BI desktop? Could you find any error message under applied steps in Power Query?

 

Per my research, this looks like a query combine problem. Please try the suggestions mentioned in below links:

Underlying error message: We cannot convert the value "[Binary]" to type Binary

Expression.Error: Cannot convert the value "[Function]" to type Function

 

Best regards,

Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello, I tried to create a table in power query, tried all variations with privacy levels and etc. Still cannot refresh model in cloud. The desktop refresh works without any problems. Also some info what I am merging: 

refersh problm.png

refrh.png

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Community Conference

Microsoft Power Platform Communities

Check out the Winners!

secondImage

Create an end-to-end data and analytics solution

Learn how Power BI works with the latest Azure data and analytics innovations at the digital event with Microsoft CEO Satya Nadella.

Top Solution Authors