cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ctappan Regular Visitor
Regular Visitor

Refresh API not working anymore: "internal service error"

Hi all,

 

We had the refresh API working successfully for a month. I have changed nothing with the ps1 script, but I had to re-install the gateway. The gateway works--I can do a manual refresh from the service interface successfully. But if I run the ps1 script I get the message "The last refresh attempt failed because of an internal service error."

 

The script is still sending the request properly--the dataset ID, client ID, etc, are all the same and I haven't changed them, and there aren't any errors from the Powershell side of things. I've tried re-installs of the gateway, new publishing of the pbix file, but have been getting this error consistently when running the ps1 file. 

 

Does anyone know what's wrong? Thanks in advance.

1 REPLY 1
Community Support Team
Community Support Team

Re: Refresh API not working anymore: "internal service error"

Hi @ctappan,

 

Based on my test, I cannot reproduce your issue here. I suggest to create a support ticket for help if you are a pro user.

 

https://powerbi.microsoft.com/en-us/support/

 

Support Ticket.gif

 

Regards,
Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.