Reply
Member
Posts: 93
Registered: ‎12-14-2016
Accepted Solution

RLS not working for Apps

Hi,
I have an App Workspace which is set to Read-only. And My workspace is on Premium Capacity. 

 

I have multiple reports to share, so I have published an app for the users. 

 

I have 6 roles on the dataset, and added test users (External User) to one of the role and asked the user to test it from his end. 

 

He is not able to see any data and got the below error. error.png


Accepted Solutions
Highlighted
Community Support Team
Posts: 1,882
Registered: ‎07-10-2018

Re: RLS not working for Apps

Hi @yash1105,

 

Based on my test, I can reproduce your issue here only in the situation that the external user has not been added into the role Members.

 

 

1.png

Could you please check whether you have added the external user to the role successfully? As adding external users to role, you should add the user as a guest firstly. For more details, please check the online document.

 

2.png

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post


All Replies
Highlighted
Community Support Team
Posts: 1,882
Registered: ‎07-10-2018

Re: RLS not working for Apps

Hi @yash1105,

 

Based on my test, I can reproduce your issue here only in the situation that the external user has not been added into the role Members.

 

 

1.png

Could you please check whether you have added the external user to the role successfully? As adding external users to role, you should add the user as a guest firstly. For more details, please check the online document.

 

2.png

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Member
Posts: 93
Registered: ‎12-14-2016

Re: RLS not working for Apps

@v-frfei-msft: Thank you for the reply.

Sorry, I didn't update this before.

 

I was helping other team, after walking through what they have done, they missed to add an external user to AAD as a guest. 

 

After adding the external guest user, it is now working fine. 

Community Support Team
Posts: 1,882
Registered: ‎07-10-2018

Re: RLS not working for Apps

Hi @yash1105,

 

If that make sense, kindly mark my answer as a solution to close the case. Thanks!

 

Regards,

Frank

Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.