cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RashmitaR
Helper IV
Helper IV

RLS error even though no roles have been created

Hi, I have a tabular model in azure analysis services . Even though I have not defined any roles in the model when I am trying to share it with a colleague , he is unable to see the data and its displays you do not have the permission to view this report as the owner has applied row level security.Could some one please help me understand the reason for this. Thanks.
1 ACCEPTED SOLUTION

Hi @RashmitaR,

It's weird. How did your share your dashboard to your colleague? Follow the steps here? If it is, please click share and check your colleague acess permission like the screenshot below.

1.PNG

Best Regards,
Angelia

View solution in original post

5 REPLIES 5
cjstudioguy
New Member

I am having the exact same issue, except I am the owner of the report.  All the users that this report & dataset has been shared with can view the report, just not me (and 1 other owner).  It was fine, then after I went into the datasets page and refreshed the dataset, I get the RLS error trying to view the report.  I can view the report fine locally, and I can re-publish.  This is the 2nd report I've had this issue with this week.  The last time I had to delete the report and dataset from PBI and republish, but then I had to reshare it and update any external links I have pointing to the report, so this solution is not ideal.  

v-huizhn-msft
Microsoft
Microsoft

Hi @RashmitaR,

You have no row level security in your SSAS database? You update the data from SSAS databased to Power BI desktop, then create report in desktop amd publish it to service, you also have not create any Row-level security (RLS)? Please confirm it. And click the dataset in Power BI service, if there is permission settings. Please share more details for further analysis.

Best Regards,
Angelia

Hi v-huizhn-msft , I have a live connect to the data SSAS database to Power BI desktop, then I have created reports in desktop and publish it to service,I have not create any Row-level security (RLS) either in the tabular model or power BI desktop. Once I click the dataset in Power BI service, I cannot see any permission settings.

Hi @RashmitaR,

It's weird. How did your share your dashboard to your colleague? Follow the steps here? If it is, please click share and check your colleague acess permission like the screenshot below.

1.PNG

Best Regards,
Angelia

View solution in original post

dilumd
Solution Supplier
Solution Supplier

I think you have to go to privacy under general settings Power BI service and give access to that user.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors