cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Published report disappears

A report that I have published successfully to web can be used for a couple of hours there, but after some more hours, the URL returns this error:

 

image.png

Anyone experience such a thing or has a clue why that is?

This is a report that fails to refresh in the service due to a problem with an API-key that I was not able to solve, but I would expect that as long as I dont attempt any refreshes in the service, a published report would survive. 

 

Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

Imke Feldmann

How to integrate M-code into your solution -- Check out more PBI- learning resources here -- Performance Tipps for M-queries




1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Published report disappears

Hi @ImkeF,

 

Sorry for the delay.

 

By my test with your URL, I cannot reproduce your issue, everything works as expected even after 2 hours.

 

This may be a temporary problem.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Community Support Team
Community Support Team

Re: Published report disappears

Hi @ImkeF,

 

Please check if you deleted the embed code accidentally.

 

In addition, have you disabled automatic refresh by selecting do not refresh on the schedule for the dataset used by the report?

 

Do you have this issue only for this report or other reports you have published to web?

 

If it is convenient, could you share the embed code which can reproduce the issue, so that we can help further investigate on it? You can upload it to OneDrive or Dropbox and post the link here. Do mask sensitive data before uploading.)

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Super User
Super User

Re: Published report disappears

Thanks Cherry!

 

Embed code is still there: 

https://app.powerbi.com/view?r=eyJrIjoiNjhmMDQ5ODAtZmZiMS00Njg3LWIxNjctYzNkMGY5ODFhYmVlIiwidCI6ImU4N... or 

<iframe width="800" height="600" src="https://app.powerbi.com/view?r=eyJrIjoiNjhmMDQ5ODAtZmZiMS00Njg3LWIxNjctYzNkMGY5ODFhYmVlIiwidCI6ImU4N..." frameborder="0" allowFullScreen="true"></iframe> 

 

(it's all public data in it)

 

Not sure about the "do not refresh"-option you mentioned, as I cannot edit the data source settings any more. Getting this error message:

 image.png

 

I copied the pbix and published it under a new name. You can see the report now here: 

https://app.powerbi.com/view?r=eyJrIjoiMjZjOTZiYWQtYmYyZi00ZjgzLWJmODQtZGIzODdhNzAyZTBkIiwidCI6ImU4N... 

But it will probably be gone in a couple of hours again.

When I try to check the data, this error-message appears: image.png

 

Which surprised me a bit, because I thought I have been able to edit the settings before.

 

Nonetheless, there is an almost similar report where I can still edit the settings, and the look like so:

 

image.png

So there is this "Keep your data up to date"-option disabled.

When I check the refresh history it is empty. 

Just published it to web here: https://app.powerbi.com/view?r=eyJrIjoiODQ0MmMyYWEtMDY0ZC00OTNkLTk0MWUtYTY1Zjg2MjQxNTFiIiwidCI6ImU4N...

 

It will be interesting to see if this report survives.

 

Thanks, Imke

 

Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

Imke Feldmann

How to integrate M-code into your solution -- Check out more PBI- learning resources here -- Performance Tipps for M-queries




Super User
Super User

Re: Published report disappears

Hi @v-piga-msft,

the link is working again!

Did you do anything to it?

Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!

Imke Feldmann

How to integrate M-code into your solution -- Check out more PBI- learning resources here -- Performance Tipps for M-queries




Community Support Team
Community Support Team

Re: Published report disappears

Hi @ImkeF,

 

Sorry for the delay.

 

By my test with your URL, I cannot reproduce your issue, everything works as expected even after 2 hours.

 

This may be a temporary problem.

 

Best Regards,

Cherry

Community Support Team _ Cherry Gao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.