cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mah65
Resolver I
Resolver I

Published Dashboard Does Not Update After Dataset Refresh

I have published a dashboard. However, after I update the dataset, the dashboard visuals do not update after clicking the refresh button in the dashboard page. I have tried the following methods of refreshing the dataset:

1) Refresh by scheduling

2) Manual Refresh

3) Refresh through Microsoft Flow

 

I also don't get any error when updating the dataset online.

The Desktop dashboard can easily get refreshed. No problem with that. 

 

I have also republished the dashboard and replaced the previous one several times, still does not work.

 

The only way it worked: I published as a dashboard with a new name. However, this gives a new link for the dashboard, which is not appropriate! (I don't want to give a new link to the stakeholders everytime!)

 

Can you please help me? What is the solution with this situation?

1 ACCEPTED SOLUTION
mah65
Resolver I
Resolver I

Hi guys,

 

I found the reason, which is funny!

The date filter did not update automatically, so data were filtered in the dashboard!

When I chose the full date range, it showed all the data.

Thanks.

View solution in original post

4 REPLIES 4
mah65
Resolver I
Resolver I

Hi guys,

 

I found the reason, which is funny!

The date filter did not update automatically, so data were filtered in the dashboard!

When I chose the full date range, it showed all the data.

Thanks.

View solution in original post

remyo
Responsive Resident
Responsive Resident

Dis you check if the credentials under Data source credentials are correct

 

remyo_1-1605857729139.png

 

mah65
Resolver I
Resolver I

Hi @remyo 

 

What do you mean parameters? I just have prepared a dashboar in Power BI Desktop and have published it into app online..

 

There is no two environments. The dashboard is reading a list from SharePoint list. Very straightforward. 

 

I just don't understand why that dashboard is not updating online.

remyo
Responsive Resident
Responsive Resident

Do you use parameters for your environment ? Are the parameters the same for your deployed report as for the one in PBI desktop ?

 

It really sounds like you are loading from 2 different environments (test / prod) 

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power BI User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

March Update

Check it Out!

Click here to read more about the March 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors