cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
FieldSalesBIGuy
Frequent Visitor

Publish dataset from desktop reports success but error in service - key didn't match

Strange error when publishing dataset. When publishing from desktop it reports success, but when I look at the service it reporting an error like below:

 

  • Data source error{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"The key didn't match any rows in the table."}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.Key","detail":{"type":1,"value":"[Schema = \"Dim\", Item = \"ProductCategory\"]"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"Expression.Error"}},{"code":"Microsoft.Data.Mashup.ValueError.Table","detail":{"type":1,"value":"#table({\"Name\", \"Data\", \"Schema\", \"Item\", \"Kind\"}, {})"}}],"exceptionCulprit":1}}} Table: Product Categories.
  • Cluster URIWABI-NORTH-EUROPE-redirect.analysis.windows.net
  • Activity IDa8faf179-8d1b-4031-a1bc-2b8c47f44f7d
  • Request IDe32949e9-9270-4f0a-855b-1ba964a25293
  • Time2020-11-25 19:46:18Z

The table being reported is different every time I try and publish or the scheduled refresh occurs. I have gone through the data model at length in desktop and see no credentials issues, no errors in power query, no problems reported in the model view, and no DAX issues on calculated columns or measures.

 

Have checked with my IT department and they claim they updated the gateway recently. I have re-attached the gateway to my scheduled refresh and double checked the credentials in the service and no problems there either - besides it seems strange that it would also happen on publish rather than manual or scheduled refresh from the service if it were the gateway.

 

Any ideas anyone?

 

 

4 REPLIES 4
v-lionel-msft
Community Support
Community Support

Hi @FieldSalesBIGuy ,

 

Has your problem been solved?

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

v-lionel-msft
Community Support
Community Support

Hi,

 

What’s your data source? What’s your connection mode?

Have you configured the gateway for the data source correctly?

Does your data model contain errors?

Solved: Expression.Error: The key did not match any rows i... - Microsoft Power BI Community

Chris Webb's BI Blog: Understanding The “The key didn’t match any rows in the table” Error In Power ...

Solved: Expression Error.: The key didn't match any rows i... - Microsoft Power BI Community

Have you updated the data source credentials in Service?

[Solved] Power BI Dataset Refresh Error – The key didn’t match any rows in the table | Data Awarenes...

What's the version of Power BI Desktop and gateway?

Several users have encountered the same problem recently, which may be related to the software version. Please update Desktop and Gateway to the latest version.

Desktop: 2.87.923.0 64-bit (November 2020)

Gateway: 3000.66.8(2020-11-25)

 

Best regards,
Lionel Chen

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Apologies Lionel - been out sick for a while with the global nasty.

 

So on return to work I can see the problem still exists. To answer your questions:

 

Data source is SQL Server, Import mode

No errors in the data model when refreshed in Desktop

None of the links to other solutions for the "Key did not match" error seem to be relevant - all data sources, tables and views still exist and refresh fine in desktop

 

Gateway was configured prior to the error, and was working fine until we moved to Premium a couple of weeks ago. Connections have been tested and gateway has been upgraded recently (having the version checked by my admin), and credentials have been updated post-upgrade.

 

Looking at the desktop version it is running on September 2.85.985.0, so that will be my next place to review I think. I will check both the gateway version and upgrade desktop (a difficult task as my dev machine is locked down and upgrades need to be pushed by our IT team, so may take a couple of days).

 

Thanks for the ideas. Will update after these attempts.

GilbertQ
Super User II
Super User II

Hi @FieldSalesBIGuy 

 

The error indicates that it is missing a key in the table called Dim ProductCategory.

 

I would have a look at that.

 

Also if you can make sure that the Gateway Version installed is 3000.66.4





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are You Ready?

Test your skills now with the Cloud Skills Challenge.

Top Solution Authors
Top Kudoed Authors