cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
unusedgrade
Frequent Visitor

Problems in updating credentials to an existing PBI Service (BigQuery)

Hello, 

 

I have an issue with invalid credentials. The dataset was formerly under a deleted email ("The dataset owner doesn't appear to be in Microsoft Azure Active Directory (Azure AD)") and I took ownership of this in order to refresh this and previous credentials are lost. The PowerBI Service gets data from BigQuery. I am unable to refresh credentials/input a new service account credentials (to the same db) as the pop-up does not offer service account login.

 

Works fine on a fresh PowerBI Desktop though. Is this a feature or something that I can work-around. 

1 ACCEPTED SOLUTION

Hey Eason,

 

I was able to resolve this problem. When authenticating/refreshing credentials:

 

Authentication method: Basic

email: <insert service account email>

password: <insert json-file content (one-line-format)>

 

This is stated here. I just got confused as there were no service account login. Link to proper documentation: https://docs.microsoft.com/en-us/power-query/connectors/googlebigquery#authenticating-through-a-goog...

 

Cheers!

 

Edit1: added link

View solution in original post

4 REPLIES 4
v-easonf-msft
Community Support
Community Support

Hi, @unusedgrade 

Please refer to the process in the link below for the takeover of the dataset.

https://www.c-sharpcorner.com/article/how-to-handle-power-bi-data-refresh-error-refresh-token-expire... 

Try to select OAuth2 in Authentication Method as depicted below and click on Sign in. 

veasonfmsft_0-1652684427562.png

If the popup does not offer service account login, clear the cache or try with other browsers.

 

Best Regards,
Community Support Team _ Eason

The log-in windows does not offer the service account -option. Tried on 3 different browsers (with/without incognito/private) and cleared cache. The database is on Google Cloud and it uses the BigQuery. Works fine on in Desktop - tried to publish it again, but stops functioning after transitions to BI Service. The snapshot just redirects to google log-in but nowhere where to input .json (no service account log-in).

 

Thanks for reply!

Hi, @unusedgrade 

I can't reproduce your problem here.

If the problem persists, it is recommended to create a support ticket to let MS engineers look into the issue on your side. 

 

Best Regards,
Community Support Team _ Eason

Hey Eason,

 

I was able to resolve this problem. When authenticating/refreshing credentials:

 

Authentication method: Basic

email: <insert service account email>

password: <insert json-file content (one-line-format)>

 

This is stated here. I just got confused as there were no service account login. Link to proper documentation: https://docs.microsoft.com/en-us/power-query/connectors/googlebigquery#authenticating-through-a-goog...

 

Cheers!

 

Edit1: added link

Helpful resources

Announcements
June 2022 update 768X460.jpg

Check it out!

Click here to read more about the June 2022 updates!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power BI Dev Camp Session 23 768x460.jpg

Check it Out!

Mark your calendars and join us on Thursday, June 30 at 11a PDT for a great session with Ted Pattison!

June 20 episode 7 with aka link 768x460.jpg

The Power BI Community Show

Join us on June 20 at 11 am PDT when Kim Manis shares the latest on Azure Synapse analytics, the Microsoft Intelligent Data Platform, and notable Power BI Updates from Microsoft Build 2022.

Top Solution Authors