cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
johnf Regular Visitor
Regular Visitor

Problems authenticating data source with Azure SQL Data Warehouse (SQL DW)

Hi.

 

I'm having an issue where I have established a connection to a Azure SQL DW instance with Power BI desktop and the credentials are working in desktop.

 

When I publish to PBI Service it asks for the credentials again for the data source. I've used all assigned accounts and up to the DB Admin but no joy. I keep getting "The credentials you provided for the data source are invalid. Please check the credentials for all the data sources."

 

I have also logged in to the SQL DW instance and tried the direct attach method from there, going back to Power BI Service (it connects and displays fields but when I tried building a report in PBI Service I get

 

"Couldn't load the data for this visual Couldn't retrieve the data for this visual. Please try again later.
Please try again later or contact support. If you contact support, please provide these details"

 

I'm stumped, what am I missing?

 

Cheers,

John.

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator v-sihou-msft
Moderator

Re: Problem with authenticating Power BI model to Azure SQLDW

@johnf

 

In this scenario, please check if you allow Azure Service Access on Azure Portal. You must have it enabled, otherwise it will always throw "invalid credential error" even you provide correct credential.

 

Regards,

2 REPLIES 2
Highlighted
johnf Regular Visitor
Regular Visitor

Problem with authenticating Power BI model to Azure SQLDW

Hi.

 

I'm having an issue where I have established a connection to a Azure SQL DW instance with Power BI desktop and the credentials are working in desktop.

 

When I publish to PBI Service it asks for the credentials again for the data source. I've used all assigned accounts and up to the DB Admin but no joy. I keep getting "The credentials you provided for the data source are invalid. Please check the credentials for all the data sources."

 

I have also logged in to the SQL DW instance and tried the direct attach method from there, going back to Power BI Service (it connects and displays fields but when I tried building a report in PBI Service I get

 

"Couldn't load the data for this visual Couldn't retrieve the data for this visual. Please try again later.
Please try again later or contact support. If you contact support, please provide these details"

 

I'm stumped, what am I missing?

 

Cheers,

John.

Moderator v-sihou-msft
Moderator

Re: Problem with authenticating Power BI model to Azure SQLDW

@johnf

 

In this scenario, please check if you allow Azure Service Access on Azure Portal. You must have it enabled, otherwise it will always throw "invalid credential error" even you provide correct credential.

 

Regards,