cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RXTurlak
New Member

PowerBi Gateway Connectivity error

we have upgraded the PBI gateway with a newer version, after not able to connect the Flat file source getting 'PowerBiEntityFramework Exception error'

RXTurlak_0-1620661695039.png

 

1 ACCEPTED SOLUTION
Ailsa-msft
Community Support
Community Support

Hi @RXTurlak 

Please check the vision for your gateway and framework .

The latest version of gateway is 3000.79.6(April 2021) and the version of the framework is at least 4.8 .

Ailsa-msft_0-1620812393862.png

You can check whether the environment where you install the gateway meets the requirements according to the link below .

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install

 

Best Regards

Community Support Team _ Ailsa Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Ailsa-msft
Community Support
Community Support

Hi @RXTurlak 

Please check the vision for your gateway and framework .

The latest version of gateway is 3000.79.6(April 2021) and the version of the framework is at least 4.8 .

Ailsa-msft_0-1620812393862.png

You can check whether the environment where you install the gateway meets the requirements according to the link below .

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-install

 

Best Regards

Community Support Team _ Ailsa Tao

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

GilbertQ
Super User
Super User

Hi @RXTurlak 

 

Sounds like you installed the 32bit version of the DOTNET framework


Can you make sure to install both the 32bit and 64bit versions of DOTNET Framework?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

GilbertQ
Super User
Super User

Hi @RXTurlak 


Can you please make sure you have got the latest version of DOTNET Framework installed on your Gateway Server?

 

https://dotnet.microsoft.com/download/dotnet-framework/thank-you/net48-web-installer





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Installed Latest .net Framework  and upgraded PBI gateway newer version then after getting this issue.

PFB Log;

SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client is not defined in registry.

SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client is not defined in registry.

SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client is not defined in registry.

 

And

 

SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319 is not defined in registry.

Helpful resources

Announcements
PBI_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!