cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MANICX100
Regular Visitor

PowerBI embed not updating

I have a powerbi report built in desktop. This has been added to a microsoft team & uploaded to the web via an embed code. Changes are reflected in the team, but not on the website.

Exporting a new embed code from the current visual just generates the same <iframe> code.

 

I have tried with a fresh profile/private mode/no-cache.

1 ACCEPTED SOLUTION
v-qiuyu-msft
Community Support
Community Support

Hi @MANICX100,

 

For embed code generated from Publish to web feature, if we update the report definition (for example, if we change its View mode) or refresh the report data, it can take approximately one hour before changes are reflected in the version of the report viewed by users. For more information, you can see: https://docs.microsoft.com/en-us/power-bi/service-publish-to-web#how-it-works-technical-details

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
v-qiuyu-msft
Community Support
Community Support

Hi @MANICX100,

 

Thank you. Will close this thread. Smiley Happy

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
MANICX100
Regular Visitor

Perfect thank you please close

v-qiuyu-msft
Community Support
Community Support

Hi @MANICX100,

 

For embed code generated from Publish to web feature, if we update the report definition (for example, if we change its View mode) or refresh the report data, it can take approximately one hour before changes are reflected in the version of the report viewed by users. For more information, you can see: https://docs.microsoft.com/en-us/power-bi/service-publish-to-web#how-it-works-technical-details

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

MANICX100
Regular Visitor

The embed code was not used on teams. Microsoft teams used the official powerbi app tab linked to the report. 

This report was then opened in the web version of powerBI, exported to an embed code which was used here as a test:
https://www.trentstudents.org/testingpage

When changes are made in desktop powerBI and published the changes are immediately reflected in the teams tab but not in the embed.

Having said that, over the weekend the changes in the above link are now there. Is there a polling period before changes are pulled through?

v-qiuyu-msft
Community Support
Community Support

Hi @MANICX100,

 

From your description, it looks like you are using publish to web feature to generate embed code, then use it to embed report in Microsoft teams, right? 

 

Which website do you mean in " Changes are reflected in the team, but not on the website."? 

 

Please use generated URL of the publish to web feature to open the report in browser to see if the data are updated. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Top Solution Authors