cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Solution Supplier
Solution Supplier

Power BI "Almost Done" Loop

Same issue as these:

https://community.powerbi.com/t5/Service/Almost-Done-Message/td-p/571469

https://community.powerbi.com/t5/Service/Cannot-access-any-reports-from-a-workspace-or-an-app/td-p/3...

https://community.powerbi.com/t5/Service/almost-done-loop/td-p/167404

https://community.powerbi.com/t5/Service/Keep-receiving-Almost-done-loop/td-p/20484

 

When I click on Apps and then a particular app I get the following which either lasts indefinitely or eventually says something went wrong.

 

Almost Done.png

 

 

 

 

 

 

 

 

 

  

None of the posts I linked ever had any resolution except the OP saying "Oh it's mysteriously working again now" and the thread gets closed.

 

I've had this issue intermittently but have currently been experiencing it for days now. I've tried Incognito and switching from Chrome to IE and still getting the same exact thing.

 

I've been able to work around this by navigating to the reports via Workspaces, but I'm also having an issue with my Publish button being gone. This is another (related?) mysterious intermittent issue that never seems to actually get resolved when asked about.

 

https://community.powerbi.com/t5/Issues/publish-app-button-disappeared/idi-p/525287

https://community.powerbi.com/t5/Service/publish-app/td-p/559144

 

There should be a yellow Publish App button here:

 

Publish Missing.png

 

 

 

 

 

 

My coworkers aren't (currently) having the same issue and it doesn't make sense as a permissions issue since nearly all these reports and apps I've created myself and the issue seems intermittent.

 

What is going on and why can no one ever get an actual resolution to these problems?

8 REPLIES 8
Highlighted
Super User IV
Super User IV

Re: Power BI "Almost Done" Loop

It's likely these are intermittent issues with the Service that get corrected. You could check the Issues forum here:

https://community.powerbi.com/t5/Issues/idb-p/Issues

And if it is not there, then you could post it.

If you have Pro account you could try to open a support ticket. If you have a Pro account it is free. Go to https://support.powerbi.com. Scroll down and click "CREATE SUPPORT TICKET".


---------------------------------------

Putting square pegs in round holes since 1972.

I have a NEW book! 
DAX Cookbook from Packt
Over 120 DAX Recipes!




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




Highlighted
Advocate II
Advocate II

Re: Power BI "Almost Done" Loop

I agree with @AlexisOlson

My clients are experiencing random problems loading apps and I sometimes am missing my Publish App button. A few page refreshes later, and it works as expected. This is a real issue that is lowering my clients trust in Power BI. 

Highlighted
Solution Supplier
Solution Supplier

Re: Power BI "Almost Done" Loop

@Greg_Deckler

It doesn't make sense to me as an intermittent issue with the Power BI Service since it can be affecting me but not my coworker in the next office.

 

There appear to be others with the same issue in the forum you linked (though I think there are other issues mixed in too):

https://community.powerbi.com/t5/Issues/Reports-are-not-working-in-the-service/idi-p/305736

 

Currently, the issue isn't affecting me, so a support ticket wouldn't do much good right now. I'm pretty doubtful that the issue is gone for good though as it has come and gone multiple times before and no one seems to know why.

Highlighted
Resolver I
Resolver I

Re: Power BI "Almost Done" Loop

Stuck in this loop as we speak !

Tried all the suggested solutions.

 

Tried multiple reports but all looping on Almost Done.

He a presentation to give in two days - couldnt have come at a worse time

Highlighted
Regular Visitor

Re: Power BI "Almost Done" Loop

Hi,

 

numerous users within our business are also being impacted by this.

we need Microsoft to stabalise the platform otherwise we will need to look elsewhere for our BI solutions.

thanks

Highlighted
Frequent Visitor

Re: Power BI "Almost Done" Loop

@AlexisOlson Did you figure out the cause of this or get a response from Microsoft?  I've had this happening past couple days and now my users are also experiencing this. Stragely if I open Incognito mode it works as expected there.

Highlighted
Solution Supplier
Solution Supplier

Re: Power BI "Almost Done" Loop

No, I haven't figured out a cause or a solution but it hasn't been affecting me recently so I haven't been looking for a fix recently.

Highlighted
Frequent Visitor

Re: Power BI "Almost Done" Loop

I worked out my issues by clearing cache and cookies.  It worked for me and my end users having the problem.  I'm still not quite sure what triggered it to be a problem in the first place though. Hopefully this helps any others finding this post to try this as a possible solution.

 

 

Helpful resources

Announcements
May 2020 Community Highlights

May 2020 Community Highlights

It’s time for another PBI Community recap!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Using the Community

Using the Community

Need help with the Power BI Community? Our 'Using the Community' support articles are a great place to start.

Galleries

Galleries

Looking for inspiration on how to present your data? Need instructional videos? Check out our Galleries!

Top Solution Authors
Top Kudoed Authors