Showing results for 
Search instead for 
Did you mean: 
Advocate I
Advocate I

Power BI online refresh - 'Microsoft.ACE.OLEDB.12.0' error



I'm getting this error when trying to refresh Power BI dataset online (scheduled and manual refresh):


Excel Workbook: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine. The 64-bit version of the Access Database Engine 2010 Access Database Engine OLEDB provider may be required to read this type of file. To download the client software, visit the following site:


In Power BI Desktop everything is working fine. The source data is located at sharepoint online and it's .xlsb file with few tabs (4 tables taken from 4 tabs in this file). 

Does anyone know how to solve this?




New Member

Does anyone know how to solve this online Error?

You can follow any one of below
1. Convert your file from .xlsb to .xlsx

2. Configure a gateway and install The 64-bit version of the Access Database Engine 2010 Access Database Engine OLEDB provider on gateway server
then create a data source for this .xlsb file (even it is on SharePoint)

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!
Advocate I
Advocate I

Same issue.  Works fine on Desktop, but on the service the error comes up.

To reiterate...

The Query looks into a SP online folder.  It is supposed to grab all the .xls files and combine them.  Works fine on Desktop, but published to the service the error occurs.

If I open each excel and save it as xlsx, then it is okay.  But there are to many files to convert. These files are sent daily and dropped into the folder automatically using Power Automate.


Not applicable

I have the same issue with xlsx files stored on sharepoint online. I fix has been found ?

Kudo Collector
Kudo Collector

In schedule refresh, Power BI only likes Excel files in xlsx extension when saved in the cloud, I had to resave all files to this extension and worked.


Annotation 2019-10-31 123359.png


Hi @Oscar_Mtz_V 


I want to know how you solved your problem , my report is on sharepoint hw can I change he type or extenseion 


Thanks a lot

@OHOODSA  you need to update the file extension on SharePoint itself

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!

Thank you @arvindsingh802 for your reply


How can I change the Extention in sharepoint 

You can download the file, update the extension and upload to sharepoint again

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!

that worked for me, thanks! 
I used the VBA-Code on to bulk resave the files. I had some files with the ending .xls and some with .XLS (Upper Case). For the latter I had to change the code by replacing xls with XLS.

Not applicable

Same here,


would like to check if theres a solution to this in PBI service, on desktop it  works fine

Not applicable



I'd like to check if there is any recommended solution to this issue, other than changing the file format of the data source.


I am facing the same problem with refreshing my dataset through Power BI Service, while the required Microsoft.ACE.OLEDB.12.0 provider is already installed on my machine (the same version as Power BI Desktop and all Office apps), and everything works fine in Power BI Desktop.


Thank you!



Community Support
Community Support

Hi @joannab ,


The download for MS Access Database Engine Redistributable can be found here. Be sure to check the same version as your Power BI Desktop is installed! For more details, please refer  to the third - party blog.


Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.
Not applicable


I'm still awaiting confirmation as to whether or not this is an issue. I am still unable to refresh my reports and will be looking for alternatives if this is not resolved. 

Thank you, but it doesn't solve the issue.


Refresh in Power BI Desktop works correctly. The issue exists when I want to refresh dataset online using scheduled refresh and manual as well.

Not applicable


I am having the same issue. 


@v-frfei-msft ,

Has this been resolved?



it hasn't been resolved on my side. I noticed the cause in this particular case is the source file format - I use .xlsb file. When I save it as .xlsm or .xlsx it's working good, but it's not the satisfying solution for me. 


I also have the same issue in another project when using .xls or .accdb source files. Everything is refreshing with no issues on desktop (Access Database Engine installed) but refresh online returns this error.


Please let me know if you find any news on that.

For the access file, what we have done, is saving the file in a local server, and then connecting to it thorugh a Gateway, this works.

I have an excel file data source with the .xlsx extension, saved in sharepoint online.

When i do the refresh from my pc it works.

When i do the refresh from powerbi service i get the Ace OLEDB error.


I can confirm the file is .xlsx, and was always connected to from sharepoint only.

Any ideas on what might be causing this?



Not applicable

I am compiling 70+ '.xlsx' files and I am unable to refresh online, but no issues on desktop. 

Helpful resources


2023 Release Wave 1 Plans

Power BI release plans for 2023 release wave 1 describes all new features releasing from April 2023 through September 2023.

Power BI Summit Carousel 2

Global Power BI Training

Make sure you register today for the Power BI Summit 2023. Don't miss all of the great sessions and speakers!

BizApps LATAM 2023

Business Application LATAM Summit 2023

Join the biggest FREE Business Applications Event in LATAM this February.

Power Platform Bootcamp

Global Power Platform Bootcamp

In this bootcamp we will deep-dive into Microsoft’s Power Platform stack with hands-on sessions and labs, delivered to you by experts and community leaders.

Top Solution Authors
Top Kudoed Authors