cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
willpage
Helper I
Helper I

Power BI dataflows and date/time columns error

I have a SQL database that contains datetime columns in some of the tables. The locale of the server is NZ English so the datetimes come through as 15/01/2020, 12:00:00 am

 

This comes through fine when I connect directly from PBI desktop to the server, and I can work with these dates no problem. Also, if I connect a PBI dataflow to the server via a on prem gateway all is good, the date columns show up just fine in the query editor in the cloud.

 

However, if I connect PBI desktop to the dataflow, the datetime columns error out with the "We couldn't parse the input provided as a DateTime value" message.

 

I have figured I can resolve this for columns where it's a date only (i.e. the time is always 12:00:00 am) by converting using Locale to Date > English (New Zealand) in the dataflow.

 

However, some of the columns do actually have a time that I want to be available in PBI desktop, but when I convert using locale to DateTime or DateTimeZone, they still error out in PBI desktop.

 

I guess this is some incompatible combination of locale settings between the SQL server, powerbi.com and PBI desktop.

 

I'd love to be able to resolve this without resorting to either splitting out the time as a string and recombining or just ignoring the time and working only with dates. I have a lot of tables and a lot of columns I want to add to my dataflows so the easiest workaround/solution to this is what I'm going for.

1 ACCEPTED SOLUTION
willpage
Helper I
Helper I

I finally figured the workaround to this issue.

 

In the dataflow entity editor (Power Query) Home ribbon, go Options -> Project ptions and choose English (United Kingdom) from the Locale drop down. It was defaulted to English (New Zealand).

View solution in original post

2 REPLIES 2
willpage
Helper I
Helper I

I finally figured the workaround to this issue.

 

In the dataflow entity editor (Power Query) Home ribbon, go Options -> Project ptions and choose English (United Kingdom) from the Locale drop down. It was defaulted to English (New Zealand).

View solution in original post

Hi @willpage ,

 

If you solved the issue, please accept your own reply as the solution.

More people will benefit from it.

 

 

Best Regards,

Stephen Tao

Helpful resources

Announcements
PBI User Groups

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

April Update

Check it Out!

Click here to read more about the April 2021 Updates!

secondImage

The largest Power BI virtual conference

100+ sessions, 100+ speakers, Product managers, MVPs, and experts. All about Power BI. Attend online or watch the recordings.

secondImage

Experience what’s next for Power BI

See the latest Power BI innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors