cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
benswift Regular Visitor
Regular Visitor

Power BI Service reports blank after scheduled refresh

Would appreciate any ideas on the following scenario on the Power BI Service:

- Scheduled refresh succeeds (confirmed in Dataset > Settings).

- But in the report everything is blank, as if the source datasets were empty, but I've confirmed that the source datasets were not empty at time of scheduled refresh.

- Refresh manually via Service solves the problem.

Doesn't make any sense that the underlying data are available (as demonstrated by the fact that other reports reliant on the same datasets are working fine), the refresh succeeds, but the report is empty.

pbi_refresh_issue_01_scheduled_refresh_succeeded.pngpbi_refresh_issue_02_but_report_blank.png

1 ACCEPTED SOLUTION

Accepted Solutions
benswift Regular Visitor
Regular Visitor

Re: Power BI Service reports blank after scheduled refresh

False alarm: We've realized this was due to empty datasets. Our Power BI refreshes were scheduled to run too early and were clashing with the procedure refreshing the underlying MySQL materialized views. Just some confusion around timezones. Thanks though.

3 REPLIES 3
ThomVF Regular Visitor
Regular Visitor

Re: Power BI Service reports blank after scheduled refresh

Do you have any Report parameters that may be set when manually refreshing but undefined when auto-refreshing?  Just a wild stab.  At first glance, seems like something is in a different state when auto-refreshing vs manual.

benswift Regular Visitor
Regular Visitor

Re: Power BI Service reports blank after scheduled refresh

False alarm: We've realized this was due to empty datasets. Our Power BI refreshes were scheduled to run too early and were clashing with the procedure refreshing the underlying MySQL materialized views. Just some confusion around timezones. Thanks though.

divya_pwbi Frequent Visitor
Frequent Visitor

Re: Power BI Service reports blank after scheduled refresh

Hello,

I am facing the same issue. I have scheduled refresh every 2 hrs.Even then all my reports are blank after each refresh. If according to you there was a clash in data refresh with the source dataset ,atleast any one of the refresh should have fetched the updated data right(because I refresh every 2 hrs). I removed all the filters and tried different browsers but no luck.My reports is always blank after a scheduled refresh.