cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Power BI Team
Power BI Team

Power BI Report web part for SharePoint Online Discussion

The new Power BI (preview) web part for SharePoint Online is now available globally for Office 365 First Release customers. The web part lets you securely embed Power BI reports from your PowerBI.com account in SharePoint Online pages so you can build secure internal portals easily. The web part requires users configuring the web part and consuming the reports to have Power BI Pro licenses.  

 

Let's use this thread to discuss the new Power BI report web part for SharePoint Online.   

 

Please read the documentation before asking a question, posting a comment below. The documentation contains answers to common questions and workaround for any known issues.

 

Known Issues:

When adding the Power BI (preview) web part, you are asked to sign-in but are not able to.

You will see error message similar to:

  • "We need you to sign in again. Once you do, we'll bring you back here."
  • "An error occurred, please try logging out and back in and then revisiting this page"

To resolve this issue, ensure your tenant is set to "First release for everyone". To enable SSO, the Power BI web part relies on new Authentication APIs provided by the SharePoint team and only available when First release for everyone is selected. See the Office 365 documentation for detailed steps

 

87 REPLIES 87
Highlighted
Frequent Visitor

Re: Power BI Report web part for SharePoint Online Discussion

I got very excited to try this out.  Been waiting a long time for this.  I am a first release customer and added a Modern Page to my SharePoint Site.  I added the Power BI (Preview) app to the page and immediately get the following error in the frame:

 

"An error occurred, please try logging out and back in and then revisiting this page. Correlation id: undefined, http response status: 400, server error code 10001, message: Missing refresh token."

 

I followed all the steps in the documentation.  Any ideas?

Highlighted
Power BI Team
Power BI Team

Re: Power BI Report web part for SharePoint Online Discussion

Did you fully sign-out of SharePoint and sign back in again? Recommend closing all browser windows after signing out.

Highlighted
Frequent Visitor

Re: Power BI Report web part for SharePoint Online Discussion

Yes I sure did.  Even cleared temporary internet files etc..  Same result in Chrome as in IE 11.

 

Now for clarification I am using an Office 365 Group with a Modern Page in that.  Is that the issue?  We have Modern Team Sites off at the Tenant Level.

Highlighted
Advocate I
Advocate I

Re: Power BI Report web part for SharePoint Online Discussion

You can't seriously expect everyone in our tenant to have a pro bi license to view the report! I hope I read that wrong....

Highlighted
Advocate I
Advocate I

Re: Power BI Report web part for SharePoint Online Discussion

Yeah - this. 

 

It's one of the most frustrating restrictions placed on Power BI, heroin dealer-style: your first hit is free. Kinda bush-league, if you ask me.

Highlighted
Frequent Visitor

Re: Power BI Report web part for SharePoint Online Discussion

I've added the web part and get a login prompt:

 

Power BI
We need you to sign in again. Once you do, we'll bring you back here.
 
Clicking on the Continue button redirects back, but never gets me past this prompt. I'm logged in to PowerBI Pro, have a Pro license, first release, etc. 

 

 

Highlighted
Power BI Team
Power BI Team

Re: Power BI Report web part for SharePoint Online Discussion

For those failing to login, please ensure your tenant is set to "First release for everyone". To enable SSO, the Power BI web part relies on new Authentication APIs provided by the SharePoint team and only available when First release for everyone is selected. 

 

See the Office 365 documentation for detailed steps:

https://support.office.com/en-us/article/Set-up-the-Standard-or-First-Release-options-in-Office-365-...

 

Highlighted
Frequent Visitor

Re: Power BI Report web part for SharePoint Online Discussion

Thanks for the reply. I've set first release for everyone, waited a bit, logged-out/closed all browser windows, but still get the SSO authentication issue. Thinking it was a page issue, I created a new a page but now the PowerBI web part is missing from the choices! We have ~30 E3 users, maybe five of those have PowerBI Pro. Do all users have to have Pro in order for any of us to add the web part?

 

edit: just took an hour or so to update, but I can authenticate now.

Highlighted
Power BI Team
Power BI Team

Re: Power BI Report web part for SharePoint Online Discussion

To add the web part to the page, the user adding it needs Pro. So not sure what exactly you're seeing. I do know that when you change First Release, it can take some time before it fully propagates. So it might just be a timing issue.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

We are thrilled to announce we will begin running a monthly webinar series named Power BI Dev Camp.

Top Solution Authors
Top Kudoed Authors