cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Power BI Report not showing data after publishing to Service

Hello,

 

 

I have designed a report using power bi desktop. Everything is working fine in power bi desktop. As soon as i publish the report to Power BI Service, the report shows data first time i access it. But after first refresh report is empty. Data is no longer there. All the tiles in the report are empty. If i publish the report again same thing happens data is there for one or two viewing then gone.

 

Any pointers will be highly appreciated. 

 

 

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

Hello @GilbertQ,

 

 

Seems like i have found the problem. as mentioned in the following thread. 

 

https://community.powerbi.com/t5/Report-Server/After-a-scheduled-refresh-the-report-has-no-data/td-p...

 

I have a page level filter on the report, which has boolean value but in the data model of report data type was string. i changed it to boolean. Now report is showing data even after schedule data refresh. So far the problem has not generated again. I think this was the problem. 

 

 

Regards,

View solution in original post

10 REPLIES 10
Highlighted
Super User IV
Super User IV

Re: Power BI Report not showing data after publishing to Service

Hi there

Is the data imported into the Power BI data model?

Also please ensure that there is no caching in your internet browser.




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

Yes. Data is inside data model. If i try to analyze the dataset of report via excel or something, i can see everything. Everything is there. And caching is disabled. 

Highlighted
Super User IV
Super User IV

Re: Power BI Report not showing data after publishing to Service

So does the data disappear after a refresh via the Gateway?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

NO. I dont have gateway. I am getting JSON data from web. Data refresh etc happens smootly. I can see the report once or twice after fresh publish to power bI cloud service. After 3rd time, data just does not show in the report. 

Highlighted
Super User IV
Super User IV

Re: Power BI Report not showing data after publishing to Service

That is weird, so the data has not been refreshed?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

Yes this is weird. Data is getting refreshed properly. Report is working properly on Power BI Desktop. Problem come when i deploy to service. After one or two time report is appearing empty. 

Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

Highlighted
Super User IV
Super User IV

Re: Power BI Report not showing data after publishing to Service

Hi there, thank link is for Power BI Report Server.

Once again I am not sure why it is happening,I would suggest logging a support ticket to get it resolved.




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Highlighted
Helper I
Helper I

Re: Power BI Report not showing data after publishing to Service

Hello @GilbertQ,

 

 

Seems like i have found the problem. as mentioned in the following thread. 

 

https://community.powerbi.com/t5/Report-Server/After-a-scheduled-refresh-the-report-has-no-data/td-p...

 

I have a page level filter on the report, which has boolean value but in the data model of report data type was string. i changed it to boolean. Now report is showing data even after schedule data refresh. So far the problem has not generated again. I think this was the problem. 

 

 

Regards,

View solution in original post

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

Community Blog

Community Blog

Visit our Community Blog for articles, guides, and information created by fellow community members.

Upcoming Events

Upcoming Events

Wondering what events you could join or have an event to promote yourself? Check out our Upcoming Events.

Get Ready for Power BI Dev Camp

Get Ready for Power BI Dev Camp

We are thrilled to announce we will begin running a monthly webinar series named Power BI Dev Camp.

Top Solution Authors
Top Kudoed Authors